Skip to Content
author's profile photo
Former Member

DI - Connection and Standard add-ons

Hi,

I have same problem running my add-on togheter with the standard add-ons : at the first run of SBO i get a variable error (Failed connecting to company DB, Error ... Method ... , Initialization failed), at the further runs all it's ok.

I have installed :

Outlook integration

DTW

Support client

Payment engine

and My add-on with UI and DI

Have you an idea of this strange behaviour ?

Andrea

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Apr 30, 2004 at 05:14 PM

    Hello,

    we have a similar problem. We realized when usind the sql server administration account SA we did not obtain the

    error.

    In my opinion this addon uses the SDK DI feature called single signon.

    Kind regards

    Peter Weber

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Peter,

      if you do not get the error using sa to sign on, you could be experiencing the OBSCommon problem.

      When a database is moved from one server to another using backup/restore you are no longer able to connect to it with Data Migration Workbench and various AddOns.

      To solve the problem you go into SQL Enterprise Manager, delete the user OBSCommon on the database in question (not from the server) and add OBSCommon again with the same user rights. This solves the problem.

      There is a SAP note on this problem: Note no. 629046

      HTH

      Regards

      Jesper Carstensen

  • author's profile photo
    Former Member
    May 04, 2004 at 10:34 AM

    Hi Peter,

    I don't understand where do you use the SA account and the single sign on, I use always SA to connect to the db

    and my add-on use the single sign-on (cookie) but i get the error.

    Why also i get this error only the first time ?

    (nobody from SAP have an answer ?)

    Best regards

    Andrea

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    May 05, 2004 at 10:59 AM

    I use SA account and i have rebuild the OBScommon account

    but i have still the same error .... only on the first run.

    Andrea

    Add comment
    10|10000 characters needed characters exceeded