Skip to Content
avatar image
Former Member

Cache Refresh Problem in SXI_CACHE Transaction in new client 700

Hi Experts,

We have installed and configured the new PI7.1 server and were checking its readiness by going through the Readiness Check Document. At one stage while we run the transaction SXI_CACHE in client 700 we are not getting the option of " Start Complete Cache Refresh" in highlighted mode. Thus we are not able to refresh the cache in client 700. But if I login in Client 001 and login using SAP* and run the SXI_CACHE I am able to see all the pipeline steps as well the option for complete Cache refresh and Adapter cache referesh is in Highlighted mode. The status is also green. Can somebody us in knowing where should we look into to solve this problem so that these option are available in the new client for refershing the CACHE.

Thanks

Regards

suk4023

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Dec 16, 2010 at 02:08 PM

    Could be access issue. Have you tried with the same user SAP* in client 700 or giving yourself all access ? Worth trying to rule out access issue.

    Thanks,

    Naveed

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Naveed,

      We have tried with SAP* login in 700 client and we are able to login but the core problem remains the same as it is....

      Thanks

      Regards

      Suk4023

  • avatar image
    Former Member
    Dec 17, 2010 at 05:53 AM

    Hi,

    Did you try doing a complete Cache refresh. The link to be used is http://<hostname>:<port>/CPACache/refresh?mode=full

    Sometimes a system restart helps too.

    Rgds,

    soujanya

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Soujanya,

      Yes we tried with the link given by you . we got the folowing error

      403 Forbidden

      SAP NetWeaver Application Server 7.11 / AS Java 7.11

      Error: You are not authorized to view the requested resource.

      Troubleshooting Guide https://sdn.sap.com/irj/sdn/wiki?path=/display/jsts/home

      Details: No details available

      Yes we tried by restaring the system too, but the status is same.

      Any more inputs will be appreciated............

      Thanks

      Regards

      Suk4023

  • avatar image
    Former Member
    Dec 17, 2010 at 06:39 AM

    Hi,

    Sorry forgot to add.. When you perform a cache refresh, the only user that works is the PIDIRUSER.

    Aslo,in the Integration Repository go to Environment u2192 Clear SLD Data Cache. Also go to Integration Directoy and clear the cache using menu Environment u2192 Clear SLD Data Cache.

    You could also check if the SLDCHECK Tcode is working fine with everything showing green.

    Lastly, try a system restart if none of the above work.

    Rgds,

    Soujanya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 25, 2010 at 08:24 PM

    Hi

    First thing first, when you install PI, the Java engine is connected to client 001. when you run the intial setup wizard for PI, the PI is configured for client 001. So, is you are talking about client 700, did you run the PI configuration wizard for 700 or not? If 700 client is not configured for PI, you cannot perform PI activity in that client.

    Thanks

    Javed

    Add comment
    10|10000 characters needed characters exceeded