Skip to Content
author's profile photo Former Member
Former Member

Can not deploy. sdm host is empty

Hi I am pretty new in this area. I installed the web Dynpro/WAS 6.4 sneak preview. I tried the basic first "welcome" application. Following the help file, I am in the step to select context menu: "deploy new archive and run". the deploy output view has three lines:

Deployment aborted

Successfully created a temporary copy

start asynchronous deployment

In the detail of "Deployment aborted" is the follwoing text:

Apr 15, 2004 10:04:57 AM /userOut/deploy ( [Deploy Thread] ERROR:

cw4.ear -> Deployment aborted


Cannot determine sdm host (is empty). Please configure your engine/sdm correctly !

I checked this forum. People said if my J2EE is ok, sdm should be ok. Then I go to Preference->SAP J2EE. The default value is remote host (host/port=computer name/3601). I also tried local host and browsed and chose each of the two items in the list. These two items are in the management console. None of them work.

Could somebody points me to the right direction.]



Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Apr 28, 2004 at 09:24 PM

    Hello everyone,

    I have the same problem. Is there anyone who can help me resolve this problem?


    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      On top of what Chong did, I followed instructions to go to the SAPMMC, locate the server node 0. Start it if not started. Continually check the Process Table. Under it, there are 3 processes namely "dispatcher", "server0" and "SDM" process. All should be at 'Running' status.

      From there my deployment is shown to be successful

      DEPLOYMENT ...

      ==> SDM host : dlim0704xxx

      ==> SDM port : 50018

      ==> URL : file:/c:/temp/temp29294CalculatorEar.ear


  • Posted on May 10, 2004 at 09:28 AM


    please check the J2EE Engine View in your IDE. You reach that through the "Window" Menu.(It virtually does the same then the console)

    Tell me if you can see SDM there.



    (All others can do alike!)

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 12, 2004 at 08:46 PM


    Open the SAP Management Console, Open the SAP Systems node, Select the System, in the context menu click start, the dispatcher and server0 also will start when you do this, but it takes a minute or two for all the processes to start.

    Once you are done with this if you go to the Netweaver Dev. Stu. and select windows->preferences->J2EE engine, status will be green.

    I also face the same problem. this worked for me.


    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I did not have this problem initially.But I had to uninstall netweaver for some reason and then when I installed it again I got this problem. In that case I followed what Kim said and I found 2 entries for the J2EE server. I selected them one by one and tried deploying the build and it worked for one of them. I think the uninstallation process has created this problem.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.