Skip to Content
author's profile photo
Former Member

Problems using an InfoSpoke with transformation via BAdI

Hi,

we want to extract data from an InfoCube with the OpenHub service (no problem so far) but have to determine one more field which is not in the cube. So we tried to use the infospoke with transformation via BAdI. When setting the flag, the necessary objects are created, and finally we get a runtime error.

After editing the InfoSpoke again, it is deactivated, but all necessary fields are filled. We created a new target structure with the additional field, and implemented the BAdI as described in the documentation. Everything (the method, the class and the BAdI) is activated, but when we try to activate the InfoSpoke, we get a warning that "Class of the BAdI implementation ZISP_ICE30001_FLASH is not active", message no. RSBO327. As I mentioned, the class has got the status "Implemented / Active".

Has anyone experience with InfoSpokes and BAdI and maybe a solution for this problem?

Greetings,

Knut

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Apr 16, 2004 at 12:10 PM

    Now I've got the solution to this problem: as mentioned in OSS-Note 538897 the views V_EXT_ACT and V_EXT_IMP have to be activated (in order to delete the cache, I suppose), after that (or a reboot of the SAP server...) the activation is no problem anymore.

    Add comment
    10|10000 characters needed characters exceeded