Skip to Content
avatar image
Former Member

HTTP/1.1 401 Unauthorized for PIAPPLUSER while testing webserv using soapUI

Developed a scenaio at PI using WebServices(synchronous) & AAE.

SOAP --> PI --> RFC

I'm using the soapUI tool to test the webservice.

Getting the following error, using my own PI login id.

HTTP/1.1 401 Unauthorized

server: SAP NetWeaver Application Server 7.10 / AS Java 7.10

www-authenticate: Basic realm="XISOAPApps"

connection: close

pragma: no-cache

content-type: text/html;charset=ISO-8859-1

date: Mon, 13 Dec 2010 18:19:49 GMT

transfer-encoding: chunked

There is no difference if I use PIAPPLUSER.

Can any one has a clue?

Thanks,

Subba

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 13, 2010 at 09:07 PM

    Hi Subbarao,

    401 is usually either with the user name and pwd only. Please recheck them and also while testing it with SOAP UI on the left side you need to give the username and pwd. Also please check few things as mentioned in this weblog:

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

    Regards,

    ---Satish

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 13, 2010 at 07:03 PM

    Hello,

    To solve it, ensure you have maintained the correct password, which MUST be the same, for all the service user on XI

    and ensure it has eight (8) characters in length.

    You may check all the places it should be maintained, such as Exchange Profile, SU01, SLDAPICUST, etc..

    Check the note below, according to your system version:

    PI 7.1:

    #999962 - PI 7.10: Change passwords of PI service users

    XI 7.0

    #936093 - XI 7.0: Changing the passwords of XI service users

    XI 3.0

    #721548 - XI 3.0: Changing the passwords of the XI service users

    Also please ensure that the user has the correct role as per link below:

    http://help.sap.com/saphelp_nw70/helpdata/en/9f/d12940cbf2195de10000000a1550b0/frameset.htm

    Regards,

    Caio Cagnani

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 13, 2010 at 08:08 PM

    hi,

    why dont you use the PI HTTP client of codeplex.com or do a test ussing the Runtime Workbench?

    i recommend you to use those tools.

    is thereany reason why you use SOAPUI??

    let me know

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rodrigo,

      Tried using PI HTTP client. I still get the error "The remote server returned an error: (500) internal server error.

      I couldn't able to use RWB due to config set up to use AAE. Since no Receiver Determination, ID, RA & SA.

      Let me know if you are aware of the above error.

      Thanks,

      Subbarao