Skip to Content
author's profile photo Former Member
Former Member

No content available for this navigation node

Hi,

I am receiving the message "No content available for this navigation node" on clicking System Administration in Portal. I receive the same messages for the other roles .

Can somebody kindly help?

Portal version: 7.01 SP7

Best regards,

Dharmi

p.s,. For previous versions, no message is being generated.

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Dec 10, 2010 at 04:14 PM

    Hello Dharmi,

    It was a change in the default behavior, then when navigating to a folder/workset/role which has no default content to be displayed, the content area should render the default content component which is configured at property "DefaultContent" in the content area iView.

    The default value for this property is:

    "pcd:portal_content/com.sap.pct/every_user/general/com.sap.portal.noCont

    entMessage"

    which is the pcd location of SAP default content component.

    This property can also be configured with the pcd location of any component, It can also be set to an empty string if it desired to continue with the old behavior (empty page is displayed).

    Also in NW 7.01 SP8 it also have changed back to the old behavior - So in case you are upgrading your system to this version no changes are needed.

    I hope this info helps you to resolve your issue,

    If so please evaluate this answer,

    It will help SDN to keep growing,

    Best Regards,

    Edison Buttenbender

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 09, 2010 at 08:46 PM

    Considering that you have the permissions to access the content, have you tried to access the navigation node directly? Like:

    http://server:port/irj/portal?NavigationTarget=ROLES://portal_content/administrator/system_admin/system_admin_role/com.sap.portal.system_admin_ws

    br,

    Tobias

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 10, 2010 at 11:04 AM

    Hi Dharmi,

    I Look on my knowledge base, and found some more sugestions to solve your case.

    1) please change one of the property in the default framework page and check if it helps.

    open the default framework page and then

    open the desktop inner page -> detailed navigation properties.

    And set the follwoing property:

    Expand First Item in Detailed Navigation = Yes

    and check if this helps in resolving the issue.

    Kindly update us with the results.

    2) give "Read" permissions for the Everyone" group to the following object: Portal Content -> Content rovided by SAP -> End user content -> Standard Portal users -> No ontent Message.

    Please remember to evaluate the replays, this incentive the SDN to keep growing,

    regards,

    Fabio

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 09, 2010 at 08:20 PM

    Hi Dharmi,

    This seems to be a now issue. Please have a look on the note 1479372 to solve your case.

    Please remember to evaluate the replays, this incentive the SDN to keep growing,

    regards,

    Fabio

    Edited by: Fabio Sarmento on Dec 9, 2010 6:22 PM

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Fabio,

      Thank you for pointing out that note but that is not the solurtion. It is the solution to if "

      "Page not found or not available" , by setting the permission you could get the ""No content available for this navigation node" instead. I want to get rid of the message itself.

      Any more ideas?

      Regards,

      Dharmi

  • Posted on Dec 10, 2010 at 04:04 PM

    Dear Dharmi,

    Disable the message is a good solution for you?

    I am sure that there is a way to disable the error message. You can just change the content of the iview "pcd:portal_content/com.sap.pct/every_user/general/com.sap.portal.noContentMessage".

    Regards,

    Fabio

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.