Skip to Content
avatar image
Former Member

Solman Diagnostics not displaying any workload data

We have completed the installation and configuration of Solman diagnostics. However, no data is displayed when I go to Solman_workcenter. I have checked all the configuration, including the agent logs and everything appears correct. I get the following error when I run a Diagnostics self-check:

===============================================

" The Introscope Enterprise Manager configuration cannot be loaded. Check the exception in detail. Global 0.057s

The Java roles assignments could not be checked : Remote error : Connection to P4 port of managed system failed Details: Failed to connect, P4 port=56004 User=administrator SID=PEP Instance Number=60Connection error to SAP System sid [PEP/60], more details about the error in agent 'atlpepr' log file (SMDAgentApplication.X.log).; nested exception is: com.sap.engine.services.security.exceptions.BaseLoginException: Exception in creating new RemoteLoginContext instance.(cause=com.sap.engine.services.security.exceptions.BaseLoginException Exception in creating new RemoteLoginContext instance.) System:PEP 7.592s

The Diagnostics agents used different J2EE user to connect to Java stack, it is recommended to use only one user (SMD_ADMIN) to connect the diagnostics agents. Please login as admin user and navigate to: Diagnostics Administration - Managed Systems - Agent Administration and assign a new J2EE user the Diagnostics agent connection type in tab "Agent connectivity". Global 0.371s

On your Solution Manager system the connectivity between the Java to ABAP stack doesn't follow the SAP performance tuning recommendations. You have 7 WEBADMIN program listeners started per Java server node, although SAP recommends a least 9. This could cause bottle-necks problem when the Solution Manager system is trying to contact the Java stack. Please navigate, as admin user, to Diagnostics Setup - Diagnostics System - Advanced Setup - Abap connectivity and set the number of Server Count in Connection Configuration to 9. Global 0.106s

atlpepr(atlpepr.celanese.com)[JC60] Wilyhost Agent step has warnings on Sun Nov 21 02:25:35 2010 : Wilyhost Agent setup finished successfully with limitations: 1 exception occured. Number of WilyHost Agents: 1, number of EP Agents: 0 System:PEP 8.933s

Some setup steps of the last Diagnostics System setup wizard execution for system PEP finished with warnings. Please navigate, as admin user, to Diagnostics Setup - Managed Systems and review "Setup Results" for the managed system PEP, in order to make sure the warnings are known and harmless in your case. System:PEP

The SAP Instance number: 60 does not support the SSO. Please make sure that the SAP Instance 60 have been setup according with the Diagnostics requirement. System:PEP

Failed to access directory /usr/sap/SMD from host 'atlpepr'. Please open witin the "Agents Administration" the "Applications Configuration" the configuration of the agent file system application (com.sap.smd.agent.application.filesystem). Select the scope 'atlpepr' and check the value of properties "smd.file.landscape_root_directories" or "smd.file.root_directories". Host:atlpepr 0.369s

2 application error(s) found in diagnostics agent atlpepr.celanese.com in last hour. Please check the agent log file (location: SMDAgentApplication.log). Host:atlpepr 1.006s

=======================================

However, when i check the Agent logs, I do not see any significant error messages.

Thank you very much for your help,

Celes

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Dec 08, 2010 at 02:19 PM

    Hi There

    Please refer to these 2 notes below

    1036695 : Data missing in overview of E2E Workload Analysis

    1435043: E2E Workload Analysis - No applicable data found

    Best Regards

    Jai Wardhan

    Add comment
    10|10000 characters needed characters exceeded