Skip to Content
avatar image
Former Member

SBO: Manage User Field Lock Error

Hi, when I try to add an user field to a table, SBO open a popup with the following message:

"The following workstations are connected to the company. Disconnect them in order to continue."

In the list is presents only my machine and no applications of mine are connected to SBO.

Someone has same idea?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Mar 10, 2004 at 06:16 AM

    Hi Nicola,

    I encountered the same problem with my local installation (Client = Server) of SBO. When I remember it correctly, it worked after I stopped the SBO server tools, but it may have been necessary to stop some AddOn I have been running in the background which had a connection via the DI API on its own. But I'm not sure which case it really was. So check and try one of those possibilities or create a message for SAP support on the SAP Service Marketplace.

    Regards,

    Frank

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 10, 2004 at 07:20 AM

    Hi Nicola,

    there are two things you can check when this mesage appears.

    a) check if any addon is running. If any is, you need to close them.

    b) check for any direct connection to the database. If you have connected to the company database via the SQL-Server Enterprise Manager, you need to either close it or point it to another database.

    You should be able to add/change fields then.

    Strangely, when adding user defined fields via DIAPI, I never received an error no matter how many workstations were connected.

    HTH Lutz Morrien

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Lutz and Frank.

      In fact, after post this message, I uninstalled all standard addons (I haven't not standard) and the issue seems solved.

      I hope a note.

      Bye to all. Nicola