Skip to Content

Upgrade SAP HR and EA HR 600 to 604 in EHP4

Hello gurus,

We did an Ehp upgrade to Ehp4 (with EHPInstaller) but the SAP_HR and EA_HR components are in version 600 (with SP53) and we want to know how to do HR upgrade to 604, how can I perform the HR component upgrade to 604?!

I read some sap notes like 1425556 ; 1064635 ; 1297231 ; 1079216 and 1143022 but I did not found any information about how to do an upgrade of both components (SAP_HR and EA_HR)!!

You have some information about it??

Best regards,

João Dimas - Portugal

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Dec 03, 2010 at 04:33 PM

    Hi João,

    Since you had to use solution manager to bring down the support stacks, you have exactly what you need.

    To go above the support package 53, use solution manager to access the HR support packages. You will need to bypass the MOPZ selection by stack for the HR applications because the HR support packages are usually above the current support package stack level. And (I just looked) I can only see the 600 versions so I believe even in EHP4 you continue to load them.

    My EHP4 system is only a trial upgrade, we do not use it for payroll.

    Hope this helps,

    Pat

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Satish,

      As you can see this message is a little old... :-| but as I remember, this problem occured because first I didn´t have the product SAP ERP 6.0 selected, instead I had the SAP ECC 6.0 and this is wrong, you must select product SAP ERP 6.0 in SMSY transaction (Solution Manager) and the other problem is what I said above, when you are running a calculation of support packages in Maintenance Optimizer (MOPZ), this show you the update option "Maintenance" or "Enhancement Package Installation" and here you choose the Enhancement Package option, after this the MOPZ ask you to Select Target where you have the Target enhancement package stack, don´t you!?... here you select the EHP5 (and the last stack) and in the same screen, if you scroll down, you can see a table with the Technical Usages that is available in EHP5 by SAP, in this list/table you must select the Human Capital Management, this specific Technical Usage contains the components EA-HR and SAP-HR for version 605.

      Best regards,

      João Dimas - Portugal

  • avatar image
    Former Member
    Dec 03, 2010 at 03:55 PM

    You sure that while performing the EHP upgrade you have selected the SAP HR and EA HR components?

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 03, 2010 at 04:04 PM

    Hi,

    We also did the the EHP4 upgrade but in our case SAP_HR and EA_HR both the patches were upgraded from 600 to 604 level, ideally in your case also if you have done EHP4 upgrade then HR package also should have upgraded to 604 level.

    It seems while upgrading EHP4, HR components are excluded from queue calculation.

    Now as your system is on EHP4, you will have to use sapehpi tool for upgrading HR packages. this would require generating xml file from solution manager, queue calculation and upgrade from ehpi tool.

    without xml file and ehpi tool SAP would not allow you to upgrade component as you are already on EHP4.

    Cheers !!!

    Ashish

    Add comment
    10|10000 characters needed characters exceeded

    • Ok Marcus...

      I forgot to tell you another thing that is related to MOPZ which is, when I perform a new maintenance transaction it does not appear that 604 version, MOPZ only calculate the support packages for SAP HR 6.00 and EA HR 6.00 and not for 6.04!

      I think it's critical to have a XML file generated by MOPZ in solution manager with EHP4 calculation that have the components SAP HR and EA HR in 6.04...

      BR

      João Dimas