Skip to Content
author's profile photo Former Member
Former Member

Use special chars in a portal component

Hi all,

I need to use special italian chars (for example: à) in my own portal components. I use JSPs, but if I use that char into jsp code the component is not compiled (see code below). If i try to include the directive

<%@page pageEncoding=”UTF-8” %>, but the component retrive the exception:

Directive pageEncoding and contentType not found.

Any hints?

Thanks and regards

Ciao

Roberto

JSP code:

<%@ taglib uri="tagLib" prefix="hbj" %>

<%--- Get the Bean named myBeanName from the application context --%>

<hbj:content id="myContext" >

<hbj:page title="Template for a portal component">

<hbj:form id="myFormId">

<hbj:gridLayout

id="myGridLayout1"

debugMode="True"

width="100%"

cellSpacing="5"

>

<hbj:gridLayoutCell

rowIndex="1"

columnIndex="1"

width="40%"

horizontalAlignment="RIGHT"

>

<hbj:textView

id="Text_ZIP"

text="Qualità"

design="EMPHASIZED"

/>

</hbj:gridLayoutCell>

<hbj:gridLayoutCell

rowIndex="1"

columnIndex="2"

width="60%"

horizontalAlignment="RIGHT"

verticalAlignment="TOP"

>

<hbj:link

id="link1"

text="Link to a page"

reference="#"

tooltip="this takes you to: http://www.google.com"

>

<% //link1.setOnClientClick("javascript:return EPCM.doNavigate('ROLES://portal_content/Folder_Test/Ruoli/RuoloRoby/Begin/Siti/roberto_page')")%>

</hbj:link>

</hbj:gridLayoutCell>

<hbj:gridLayoutCell

rowIndex="2"

columnIndex="1"

colSpan="2"

width="100%; writing-mode:tb-rl"

horizontalAlignment="CENTER"

verticalAlignment="TOP">

ciao mondo

</hbj:gridLayoutCell>

</hbj:gridLayout>

</hbj:form>

</hbj:page>

</hbj:content>

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Mar 09, 2004 at 06:46 PM

    Hi Roberto,

    Try using <Meta> tag of plain HTML.

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

    If you still see the problem then make sure that you have the following in java startup options.

    -Dhtmlb.useUTF8=X

    -Dfile.encoding=ISO-8859-1

    lakshmi

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.