/scripts/ahub.form.attachments.js
0

ST-API upgrade component not fitting into target installation

Dec 07, 2016 at 11:56 PM

257

avatar image

Hello

While upgrading ST-A/PI to 01S_731, I get this message for on of the old third party add ons which we are not using anymore & we are not in any support contract with them.

"component not fitting into target installation"

In the message it says this third party component has a pre-requisite of SAP_ABA 620 but our system is already on SAP_ABA 740.

I m not able to proceed with upgrading ST-A/PI because of this, as I cannot contact the vendor for the Attribute Change Package of the third party component

Is there a way that I can ask SAINT to not check this part or if I can remove the third party add on from the system ?

Thanks

Shradha

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

shradha sampat Jan 10, 2017 at 10:34 PM
1

Thank you All !!

We contacted the third party vendor & they agree to provide an ACP for it

Share
10 |10000 characters needed characters left characters exceeded
Steven Patterson
Dec 12, 2016 at 04:39 PM
0

The best way to go back is if you have an old backup before you installed the add-on which you can restore. Otherwise the only other options is to fix the issue and move forward.

Share
10 |10000 characters needed characters left characters exceeded
Matt Fraser
Dec 12, 2016 at 05:22 PM
0

Hi Shradha,

I'm sure restoring to a very old backup from before you upgraded from 6.20 to 7.40 is not going to work too well for you. Some ABAP Add-Ons are deinstallable, if certain preconditions are met, but not all are. So, check in SAINT first to see if it offers this option (the process is described in the online manual available within SAINT). See Note 2011192 (Uninstalling ABAP Add-Ons) for more information. If this works, you'll probably also have to use the SUM tool for the "Correction of Installed Software Information" process (see Note 1816146).

Most likely, though, you will need to engage SAP Customer Support, by logging an Incident against component BC-UPG-OCS-SPA.

There are tables where the component version information is stored, and theoretically you can "trick" the system into believing the component is gone. However, you would only go that if you were absolutely certain the component was already uninstalled and the tables were therefore just incorrect. And, this CISI process of SUM should do this for you in a supported way.

Cheers,
Matt

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Oh, and I added "Software Logistics" to your tags on this question, as that's really what you're asking about.

0

Hi Shradha,

interesting is that you were able to upgrade to SAP_BASIS 740 without any issues.
Would you please attach the error message and what you choose from SAINT? Is it possible that you would like to update ST-A/PI and on the next screen you choose all available components to calculate the target system component vector?

Maybe you can provide some screenshots by adding a word document which contains them.

Best regards,
Andreas

0
Harish Karra Jan 10, 2017 at 10:50 PM
0

Hi Shradha,

I would de-install it if it is not being used (One time fix) so that issue can be fixed for long.

Regards,

Harish Karra

Share
10 |10000 characters needed characters left characters exceeded
Skip to Content