Skip to Content
avatar image
Former Member

Error while running a java webservice

Hi All,

I have a java project which uses MDM Java API's added as External jars. I had exposed this Java class as a webserivce, now when i run the webservice thru webservice navigtor i get the below error.

The same runs fine with java, this problem is only with webservice

An error has occurred. Maybe the request is not accepted by the server:

com.sap.mdm.server.RepositoryIdentifier

Response:

SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>com.sap.mdm.server.RepositoryIdentifier</faultstring><detail><ns1:java.lang.NoClassDefFoundError xmlns:ns1='http://sap-j2ee-engine/error'>com.sap.mdm.server.RepositoryIdentifier</ns1:java.lang.NoClassDefFoundError></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

MyJava Class

public String GetConnectionDetails(String args){

//Create Connection

try {

connections = ConnectionPoolFactory.getInstance(serverName);

RepositoryIdentifier reposId = new RepositoryIdentifier(repositoryName,dbmsName,DBMSType.ORACLE);

GetRepositoryRegionListCommand regionListCmd = new GetRepositoryRegionListCommand(connections);

}catch (ConnectionException e) {

e.printStackTrace();

}

//commented remainig code

Any one please hellp

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Dec 10, 2010 at 09:15 AM

    Hi,

    I think the problem lies in the MDM-JAVA-API, as you are receiving a NoClassDefFoundError. I've seen a similar problem where the error was solved by deploying a newer Java API. Maybe the following documentation can be helpful:

    http://help.sap.com/saphelp_nwmdm71/helpdata/en/61/a65ad5dfe74524984c8f46f733efeb/content.htm

    Regards,

    Désiré

    Add comment
    10|10000 characters needed characters exceeded