Skip to Content
author's profile photo Former Member
Former Member

How to connect SAP R/3 4.6C to Integration Builder (Design)

I am trying to import a RFC from 4.6C in Integration Builder (Design). I have Imported Software COmponent Version 4.6C in IB. In connection data for import I had put proper (case sensitive) values, group as PUBLIC. Saved & activated the configuration. After that right clicked on Imported objects - Inport RFC/IDoc - A window for entering suerid & password appears. After entering the details I get error "Unable to establish connection to R/3 system" The userid & password is correct with proper authorizations.

Can you tell me how to solve the problem? With the same way I am able to connect to 4.7 system. Is there other way to connect to 4.6C systems?

Add comment
10|10000 characters needed characters exceeded

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 23, 2004 at 09:56 AM

    Hi!

    > that right clicked on Imported objects - Inport

    > RFC/IDoc - A window for entering suerid & password

    > appears. After entering the details I get error

    > "Unable to establish connection to R/3 system" The

    > userid & password is correct with proper

    > authorizations.

    Have you inserted "sapms<SID> 36<xx>/tcp # SAP System Message Port" into the /etc/services of the Integration Repository machine?

    Regards, Tanja

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi!

      > I had added the entry in the etc/services

      > file.

      > But still I am not able to connect. Do I need to

      > restart the Integration Repository m/c?

      I had the same problem but in my case it worked without restarting the Integration Repository when I made the appropriate entries to the etc/services file.

      Regards, Tanja

  • author's profile photo Former Member
    Former Member
    Posted on May 04, 2004 at 02:16 PM

    Hi there!

    Has your problem been solved in the meantime? We are experiencing exactly the same problem. We have been advised to delete and newly create logon group SPACE and use it for logon in the Import Popup. Unfortunately, this didn't help. If the problem has been solved in your case, I would be very thankful, if you'd share the solution with me...

    Thanks, Kathrin!

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 04, 2004 at 08:53 PM

    hello :

    Usually message server port 3200 should be used in etc/hosts for the back end system.

    Please make sure you have an entry like this -

    /H/<server> or IP /S/3200 on xi box for the back end system.

    Also in the backend system create a logon group using SMLG and make sure you specify the same logon group under group for connection data in IR for software component.

    Hope this helps.

    Best Regards,

    Rajan Kedambi

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 05, 2004 at 01:50 PM

    Bhush:

    can you check your RFC Adapter configuration file. 4.6C is not a unicode system.In your configuration file you might have to set unicode =0.

    hope this helps.

    Regards,

    Praveen

    Add comment
    10|10000 characters needed characters exceeded