Skip to Content
0

IDOC occurrence change problem

Dec 07, 2016 at 07:22 PM

97

avatar image

Hello Expert,

As per my requirement i want to receive multipal idoc in single message , So i want to change IDOC occurrence to maxoccurrence ="unbounded"

Once i upload changed xsd in my external definition in my system it is showing some error :

"Unable to convert imported document to WSDL Reason: Error when parsing an XML document (Element type "xsd:element" must be followed by either attribute specifications, ">" or "/>".)Check selected category"

For your reference i am attaching the doc .

Please help me for this issue .

Regards

P.Singh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Evgeniy Kolmakov Dec 08, 2016 at 12:57 AM
0

Hi Pankaj!

As Harish has already said, add the space before maxOccurs="unbounded" attribute to separate it from previous attribute type.

Regards, Evgeniy.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thanks Evgeniy for your suport

0

Glad that it helped.

By the way, I guess you should mark Harish's answer as the best answer. He was absolutely right and I've just slightly clarified it :-)

Regards, Evgeniy.

0
Manoj K Dec 08, 2016 at 12:45 AM
1

i believe you are doing idoc packing i. e outbound case so you really need not change the occurence just make you have enabled idoc packing in partner profile amd idoc sender channel thats is enough you ll get multiple idocs in one message , in case if it is inbound then you can chnage the occurenec of idoc uisng signature tab in message mapping .

Br,

Manoj

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Dec 07, 2016 at 11:55 PM
0

Hey Pankaj.

Can you please redownload the original IDoc XML definition and redo your change. Add spaces after you close your quotation marks as well.

https://wiki.scn.sap.com/wiki/display/XI/Changing+the+Occurrences+of+Standard+IDOC

If you are still having difficulty please send the XSD text so i can copy it and try in my system as you may have accidentally broken some of the syntax which your error is alluding to.

Share
10 |10000 characters needed characters left characters exceeded
Harish Mistri Dec 08, 2016 at 12:04 AM
0
,

Hi Pankaj,

it seems to be problem with semantics in XSD. please make sure that XSD:elements is in one line with no line break. there should be space before max occurance and space after "unbound".

refer the below link for more details

https://wiki.scn.sap.com/wiki/display/XI/File+to+Multiple+IDOC+Splitting+without+BPM

regards,

Harish

Share
10 |10000 characters needed characters left characters exceeded