Skip to Content

WSDL Policy Problem

Hi All

I'm facing this issue...

My Process Integration version is: 7.1 EHP1

When create a WSDL, this comes with the WS_POLICY by default in true!

and thats my problem....

I'll try to explain all my Steps:

1.- in the ESR I Have created all the necesary (DT, MT, SI, MM, OP)

2.- in te Directory, i Have created all objects: Receiver, Sender, I.Det, R.Det.

3.- Right click on Sender Agreement -> Display WSDL

4.- this windows comes with 2 things: 1 the WSDL URL and 2, the WSDL per se

if I download the WSDL, I can change manually the ws_policy from "true" to "standard" or "false", and with this it works fine... but this solutions doesn't works for me... I need to use the WSDL URL (http://XXXXX:50100/dir/wsdl?p=sa/10eee4f1d18632f182bf5eb4b42cfcdb)

but, if I use, the WSDL URL, the definition inside it comes with ws_policy = TRUE and I can't change it.

I have followed this link: /people/holger.stumm2/blog/2010/03/19/wsdl-wspolicy--what-is-it-und-how-can-i-get-rid-of-it-in-pi

wich talks about how to replace the call of WS_POLICY with STANDARD,

this is my real URL:

http://XXXXX:8000/sap/bc/srt/wsdl/sdef_ZSI_LABORATORIO_GS02_REQUEST_S/wsdl11/ws_policy/document?sap-client=100

this is my URL changed.

http://XXXXX:8000/sap/bc/srt/wsdl/sdef_ZSI_LABORATORIO_GS02_REQUEST_S/wsdl11/STANDARD/document?sap-client=100

but I see than this is pointing to SAP ECC and not to PI... here I'm confused.

if this works I could see the messages from Legacy to PI in the SXI_MONITOR???

basically what I can see with this is: a direct call to the "service interface" wich I have activated in the SPROXY.

But I think than the Policy status can't be changed in PI...

when I look in the Service Interface WSDL TAB I can see, than already it has the policy in true, I have set the Security profile to "NO" but the WSDL TAB shows: <wsp:UsingPolicy wsdl:required="true" />

if someone knows how to fix it I'll apreciate it

Thanks and Regards

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 10, 2011 at 12:46 PM

    Hello,

    I know it's an old topic, but we've got the exact same problem here.

    We want to remove the policy tags in the WSDL generated by PI (7.11), or at least set <wsp:UsingPolicy wsdl:required="false" />

    Our webservice is consumed by another application that stumbles upon these tags. Now, everytime we have to remove these tags manually. Hope someone can provide me with a solution. Thanks in advance.

    Regards,

    Floris

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 05, 2013 at 03:51 PM

    Hello Guillermo,

    did you solve that? Can you share the way in case?

    Regards

    Paolo

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 20, 2014 at 07:18 AM

    Hello Guillermo,

    i have the same problem. Have you resolved the problem? thx.

    regards,

    Fanglin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 16, 2015 at 01:16 PM

    Hello all,

    according to SAP Note 1857379 there is currently no other option besides manually editing the wsdl

    best regards,

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.