Skip to Content

Tag "tableView" contains invalid attribute values.

Hi,

I'm working my way through the BSP extension examples in the WAS programming book, and keep getting the following error every time I use the tableView extension:

<HTMLB:tableView>: (Attribute=columnCount) The attribute does not exist. (Compile time validation error).

Tag "tableView" contains invalid attribute values.

The error occurs even when I try to activate one of the built-in example BSP applications in the miniBSP. Is it my installation that lacks something, or is this a known error?

I'm on XP Pro, Explorer 6, miniBSP (6.20)...

trond

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Nov 19, 2003 at 04:04 PM

    As always s... strange things happen in the last minute and when providing the Mini SAP system a serious bug entered it shortly before the CDs have been pressed.

    (For those with OSS access the solution is described in Note 621674)

    Here's how to proceed:

    Edit the method INITIAL_CHECKS of the class CL_BSP_ELEMENT_CT_ATTR_VALID

    and delete following three three lines:

    IF attribute_info IS INITIAL.

    me->Error( name = name msg = 'Der Attribute existier nicht. (Compile Time Validation Error)'(009) ).

    ENDIF.

    You will be asked to create a transport request for this modification (do it) . Don't forget to activate the changed class!

    Restart the se80 and activate the whole BSP application again. Then it works.

    Its probably a good idea to release the created transport request (se09).

    best regards,

    Dirk

    Add comment
    10|10000 characters needed characters exceeded