Skip to Content
author's profile photo
Former Member

Excel in place

Hi,

I am createing a report in ALV and when I use the option " Excel in Place" from the toolbar, I get the Excel spread sheet in the body of the report, but with no data in it. When I change the layout back to grid, my data is back in the report.

Any thoughts out there?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Posted on Oct 24, 2003 at 05:44 PM

    You have to change the security settings for the macros in excel for this to work. Make sure that no other spreadsheets are open and open up MS Excel. Then go to Tools -> Macro -> Security. Then click the Trusted Resources tab. Make sure that all of the checkboxes are checked (Trust all installed add-ins and templates and Trust access to Visual Basic Project). When you try to run the Excel in place make sure that no other excel files are open. We have found there is a problem when trying to use this ALV feature when an excel file is already open. The above solution usually solves the problem if it doesn't try disenabling all Add-ins.

    Hope this helps.

    Mike McCane

    Add comment
    10|10000 characters needed characters exceeded