Skip to Content
avatar image
Former Member

File to IDoc - Partner No. problem

Hi,

I am trying to sent an IDoc to ERP system from PI. I made all configurations but I get an error in ERP in we02. It says that the Partner No. is incorrect. When I look at the Partner No. I see that it has the entry "TODO". But it must be the system name, like xxxclnt400

Why is PI sending the Partner No. as TODO??

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 25, 2010 at 12:21 PM

    Hi Chris,

    Ensure that there are no changes done in SLD.

    please check the receiver agreement object and field - header mapping - sender service

    is it the same as with other flows ? you can put there the business system which has the correct

    logical system name in SLD - so it will go correctly to ERP

    Check whether the control record data is taking from the Payload.

    Thanks,

    Edited by: Hareenkumar on Nov 25, 2010 1:25 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 26, 2010 at 04:33 AM

    Assuming that you have done all the configs properly (sm59, IDX1, we20 etc)

    1) IDOC Receiver channel --> uncheck the option Apply Control record from Payload

    2) In Message mapping disable the control record field of IDOC.

    3) ID --> Business System --> Edit --> Adapter Specific Identifiers --> check what values you see.

    Regards,

    Abhishek.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 26, 2010 at 06:25 AM

    Hi Chris,

    Make sure while creating Business system in SLD, you have provided Logical system same as Logical system defined in R/3 ( BD54). Also ensure in Integratgion direcory ID --> Business System --> Edit --> Adapter Specific Identifiers you have same Logical system for Business Ststem as per above post.

    Regards,

    Vinod

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 30, 2010 at 08:32 AM

    It got solved after I checked the checkbox in IDoc adapter

    "Take sender from payload"

    "Take receiver from payload"

    Thanks all.

    Add comment
    10|10000 characters needed characters exceeded