Skip to Content
avatar image
Former Member

Unable to start a BSP application

I have created a BSP application and activated it. Properties tab of the BSP page has the following URL : http://sapdevqa:1080/sap/bc/bsp/sap/zbookshop/default.htm When I test this application, system is trying to access default.htm page at this address and coming out with an error. But the default.htm page itself is at the following address on the Sap server : http://sapdevqa:1080/sap/bc/bsp_dev/sap/zbookshop/default.htm

Does anybody know why the system is accessing the service ZBOOKSSHOP in BSP directory instead of BSP_DEV ?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Nov 06, 2003 at 12:12 PM

    Hallo Ramesh,

    For reading I will give you at least two critical documents:

    BSP Trouble Shooting: Browser Settings

    /people/mark.finnern/blog/2003/09/18/bsp-trouble-shooting-browser-settings

    BSP In-Depth: Fully Qualified Domain Names

    /people/brian.mckellar/blog/2003/09/25/bsp-in-depth-fully-qualified-domain-names

    The URL you use of /sap/bc/bsp/... is correct. Do not change this. The bsp_dev is for webdav access, and you should not run BSP via it. It will not make you happy.

    You problem is called FQDN. The problem is with "sapdevqa". It should be "sapdevqa.domain.ext".

    This is a normal configuration problem. You can find references to it in any number of OSS notes. Including the attached BSP-FAQ in OSS note 616900. Also documented. You are looking for something called icm/host_name_full (or was it full_host_name?).

    regards, brian

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Brain,

      Thanks. It works now.

      As suggested by you, I have updated the profile parameter icm/host_name_full with FQDN and also had to update hosts file on unix box with FQDN against the IP number. The articles suggested by you are also very useful.

      cheers

      Ramesh