Skip to Content
author's profile photo Former Member
Former Member

Delete Masterdata in Background

Hi there

I have a problem with deleting unnecessary masterdata records. When I submit the delete from the popup menu "Delete Masterdata" in Transaction RSA1 the task runs in dialog mode. After an hour the task ends with time out because there are about 1 Mio. records in the InfoObject an it is used in several InfoCubes. Therefore, the system checks all records if they are used in any InfoCube.

My Question now, is there a way the execute the delete of masterdate in background (batch)? I haven't found any information in the Online-Help or SAP-Notes.

Thanks for your help.

Kind regards,

Hansjörg Luzi

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Feb 22, 2004 at 11:30 PM

    I don't know how you can do this in background (could not see anything in process chains or ABAP program) but as a workaround you could increase the limit for foreground processing.

    In RZ11 change rdisp/max_wprun_time

    The setting remains in effect until you change it again or the system is restarted. If you want to change the value after restart use RZ10.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.