Skip to Content
author's profile photo
Former Member

SAP Engine Service Problem

i have a big problem with developed iviews under the sap ep5 sp5.

with the command line version of the sap engine everthing works fine.

when i start the engine as service non of the developed iviews works.

i get the following errors:

com.sapportals.portal.prt.component.PortalComponentException: Error in service call of Portal Component

at com.sapportals.portal.prt.core.PortalRequestManager.handleRequestException(PortalRequestManager.java:647)

at com.sapportals.portal.prt.core.PortalRequestManager.callPortalComponent(PortalRequestManager.java:295)

at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:198)

at com.sapportals.portal.prt.component.PortalComponentResponse.include(PortalComponentResponse.java:231)

at com.sapportals.portal.prt.pom.PortalNode.service(PortalNode.java:475)

at com.sapportals.portal.prt.core.PortalRequestManager.callPortalComponent(PortalRequestManager.java:291)

at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:198)

at com.sapportals.portal.prt.core.PortalRequestManager.runRequestCycle(PortalRequestManager.java:483)

at com.sapportals.portal.prt.portalconnection.sapnative.DelegatedPlugIn.handleRequest(DelegatedPlugIn.java:730)

at com.sapportals.portal.prt.portalconnection.sapnative.PortalPlugIn.handleRequest(PortalPlugIn.java:132)

at com.sapportals.portal.prt.dispatcher.Dispatcher.service(Dispatcher.java:635)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.inqmy.services.servlets_jsp.server.InvokerServlet.service(InvokerServlet.java:126)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.inqmy.services.servlets_jsp.server.RunServlet.runSerlvet(RunServlet.java:147)

at com.inqmy.services.servlets_jsp.server.ServletsAndJspImpl.startServlet(ServletsAndJspImpl.java:789)

at com.inqmy.services.httpserver.server.RequestAnalizer.checkFilename(RequestAnalizer.java:644)

at com.inqmy.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:305)

at com.inqmy.services.httpserver.server.Response.handle(Response.java:166)

at com.inqmy.services.httpserver.server.HttpServerFrame.request(HttpServerFrame.java:1156)

at com.inqmy.core.service.context.container.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:36)

at com.inqmy.core.cluster.impl3.ParserRunner.run(ParserRunner.java:30)

at com.inqmy.core.thread.impl0.ActionObject.run(ActionObject.java:46)

at java.security.AccessController.doPrivileged(Native Method)

at com.inqmy.core.thread.impl0.SingleThread.run(SingleThread.java:132)

i hope someone can help me!

best regards

thomas kuri

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Posted on Feb 21, 2004 at 08:49 PM

    I think you simply forgot to reference the used service in your default.properties

    Add comment
    10|10000 characters needed characters exceeded