Skip to Content
author's profile photo Former Member
Former Member

eclipse debugging freeze...

Hi,

did anyone experience a eclipse freeze during debugging?

It freezes at the dialog: "Trying to establish Connection" under Run->Debug->Remote App -> ProjectName->Debug

The only solution to this problem seems to be a restart of the server...

Cheers Jens

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Feb 24, 2004 at 10:08 AM

    This normally happens, when eclipse tries to connect to port x, but at port x some other server is running (and not the jvm's remote debugging port). Then eclipse waits/hangs until this connection times out. (which can last some minutes).

    Recheck your server configuration to ensure that on your desired debugging port, there is really the jvm listening.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.