Skip to Content
author's profile photo
Former Member

Access is denied

Hello                                                                  Â

We have a problem that occurrs only with 3 of 16 users that are connected

to our Portal. The problem occurs when the user tries to connect to the

Portal, he/she gives the user and password and when the Portal screen appears

It doesnot shows the info corresponding to the top level navigation bar

and shows an error message "access is denied". In order to correct this

problem the user has to press refresh buttom in the Portal in order    Â

to display or appear the top navigation bar(roles and Pages).          Â

We applied the notes 604353 and 604208 related to this issue but we    Â

didnt obtain favorable results.                                        Â

Two of our users are using windows XP and one is using windows 2000Â Â Â Â Â

The IE is 6.0Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â

SAP R/3 version is R/3 46c                                             Â

The Portal version that we have installed is: EP5 SP5 Patch 3 Hotfix 1Â Â

The J2EE version is :J2EE 6.20 Patch 16Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â

sapgui 6.20 compilation 4Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â

Does anyone know what could be the problem

Thanks in advance for any help related to this topic                Â

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Dec 21, 2003 at 04:57 PM

    I had a similiar problem, switched to SP6 - problem still there - and then HF2: solved.

    But this is probably not a solution for you.

    Sometimes, you just have to clear you browser chache, because some user do not update *.js in each session per deafult. If the problem resides:  Open an OSS message please.

    BR,

    Oliver

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      If you upgrade to SAP 2004

      You cannot run that application on a diferent server where you have your license installed...

      Move your ASP Application to the same server where you install the license (maybe is the same server where you have your production database)

      This is going to solve errors for:

      1. Cannot connect to SBOCommon

      2. Access is denied

      This is the code that you have to use to connect to your data base

      =============================================

      Dim vCompany As SAPbobsCOM.Company

      vCompany = New SAPbobsCOM.Company

      vCompany.DbServerType = BoDataServerTypes.dst_MSSQL

      vCompany.Server = "YOUR SAP-SERVER"

      vCompany.CompanyDB = "YOUR DATABASE"

      vCompany.UserName = "YOUR USER"

      vCompany.Password = "YOUR USER PASSWORD"

      vCompany.DbUserName = "YOUR DATABASE USER" '(sa)

      vCompany.DbPassword = "YOUR DATABASE USER PASSWORD"

      vCompany.UseTrusted = False

      =============================================

      good luck fellas