Skip to Content
author's profile photo Former Member
Former Member

Pricing procedure base condition not getting called in CRM

We are using IPC pricing in CRM for creating complaints. We have imported our pricing procedure from ECC. There is a pricing routine condition ZPAL which uses the condition(Requirement) : 937 and Base Formula 903. We have coded both requirement 937 and Base Formula 903 in IPC and assigned to the 937 and 903 in /n/sapcnd/ueass. When the requirement 937 is met they system is not calling the Base Formula 903. Can any one please suggest how to call base condition?

Thanks,

Rajinikanth G

Edited by: Rajinikanth G on Nov 11, 2010 7:58 AM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 11, 2010 at 09:05 AM

    HI,

    Use standard sequence for find error:

    1. Activate PRC_TRACE wth value "X" (upper case) in SU3

    2. Check how system find condition sequence.

    Denis.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 11, 2010 at 09:09 AM

    Hi Rajnikanth,

    How do you find the 903 is not getting called?.

    My doubt is the condition type ZPAL may be have some error.

    Please check the trace whether condition is in green color.

    Regards

    shanto aloor

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 15, 2010 at 09:49 AM

    Hello,

    would recommend to enhance your condition base formula code with some log statements (see guide attached to note 809820) to prove that it is really not called. I suspect there might be an issue with the Java implementation of your formula.

    Best Regards,

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thnaks Machael.

      Yes, we have added log statemnts in requirement code and we did not see them in VMC log. So, the routine is not getting called. Can you please suggest what can we do to call the routine?

      Thanks,

      Rajinikanth G

  • Posted on Nov 15, 2010 at 04:27 PM

    Hi,

    so you did not see the log output of your formulas although you did switch the VMC log to debug mode(http://help.sap.com/saphelp_crm70/helpdata/EN/44/b7dfaa6c154cd19db4ad02f4f65b25/content.htm)? Did you use the right application server during analysis?

    Best Regards,

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.