Skip to Content
avatar image
Former Member

Data Servers Enabled Servers not visible

Hi,

We seem to be having a problem with xMII at the moment. Enabled servers within Data Servers are not visible. The windows is completely blank. After unchecking Show Only Enabled Server we get the following error as below and no connectors are visible. The version of xMII being used is 11.5. Any pointers on how to solve this.

Thanks,

Vanshi

Error. The server encountered an unexpected condition which prevented it from fulfilling the request.

java.lang.NullPointerException

at pagecompile._Admin._Server_xjsp._jspService(_Server_xjsp.java:138)

at com.newatlanta.servletexec.JspHttpJspPage.service(JspHttpJspPage.java:41)

at com.newatlanta.servletexec.JspServlet.service(JspServlet.java:1036)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

at com.newatlanta.servletexec.SERequestDispatcher.forwardServlet(SERequestDispatcher.java:638)

at com.newatlanta.servletexec.SERequestDispatcher.forward(SERequestDispatcher.java:236)

at com.newatlanta.servletexec.SERequestDispatcher.internalForward(SERequestDispatcher.java:283)

at com.newatlanta.servletexec.SEFilterChain.doFilter(SEFilterChain.java:96)

at com.lighthammer.cms.system.CMSFilter.doFilter(Unknown Source)

at com.newatlanta.servletexec.SEFilterChain.doFilter(SEFilterChain.java:60)

at com.newatlanta.servletexec.ApplicationInfo.filterApplRequest(ApplicationInfo.java:2159)

at com.newatlanta.servletexec.ApplicationInfo.processApplRequest(ApplicationInfo.java:1823)

at com.newatlanta.servletexec.ServerHostInfo.processApplRequest(ServerHostInfo.java:937)

at com.newatlanta.servletexec.ServletExec.ProcessRequest(ServletExec.java:1091)

at com.newatlanta.servletexec.ServletExec.ProcessRequest(ServletExec.java:973)

at com.newatlanta.servletexec.ServletExecService.processServletRequest(ServletExecService.java:167)

at com.newatlanta.servletexec.ServletExecService.Run(ServletExecService.java:204)

at com.newatlanta.servletexec.HttpServerRequest.run(HttpServerRequest.java:487)

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 04, 2010 at 09:38 PM

    Give these URL's a try:

    /Lighthammer/Illuminator?Service=SystemInfo&Mode=ServerList
    
    /Lighthammer/Illuminator?Service=SystemInfo&Mode=ServerList&Mask=Disabled

    They should essentially give you the list of active and disabled data servers (much like the jsp page is trying to do)

    It is possible you managed to get an invalid name in the system and that's causing the error.

    You could also look carefully into the Server.xml file in the Conf directory.

    A ServletExec restart will also cause the system to re-read the file and log out trace information about the data server in the cms.log file (you'll see Loading Servers... and then you should see them one at a time).

    Add comment
    10|10000 characters needed characters exceeded