Skip to Content
avatar image
Former Member

Selection event not firing for iGrid when 'Cell Selection' is enabled

Working through some issues while migrating from MII 12.0 to MII 12.1.7 (Build 44)

I have an iGrid setup in scoreboard mode. If the "Allow Cell Selection" property of the display template is set to true, the selection event will not fire. Both "Allow Selection" and "Allow Deseletion" are enabled as well.

Is this the desired behavior? Shouldn't the selection event still fire.

If I disable the parameter, my solution will work, however it looks ugly because the entire row is now selected instead of the single cell the user was clicking on.

Rod

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Nov 03, 2010 at 04:19 PM

    Rod,

    Try disabling Selection and Deselection. Leave Cell Selection enabled and try again. I don't think you can have both enabled at the same time.

    Regards,

    Mike

    Edited by: Michael Appleby on Nov 3, 2010 5:19 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      No Dice Mike.

      My testing indicates that 'Allow Selection' must be enabled in order for 'Allow Cell Selection' to have any effect.

      However, I did find the problem. As stated I'm using the 'SelectionEvent'. In 12.0.5 this would be fired even with 'Allow Cell Selection' enabled. Evidently not the case in 12.1. I changed it to the CellSelectionEvent, and it now works fine.

      Rod