Skip to Content
0

Eclipse (ADT) - Neon Repository down?

Dec 07, 2016 at 07:50 AM

112

avatar image
Former Member

Hi,

since yesterday I'm trying to setup a new Eclipse environment to start programming with this tool.

After a successful installation of the latest Eclipse Java EE IDE (NEON) and the appropriate Java runtime engine, I tried to reach the repository at https://tools.hana.ondemand.com/neon to no avail so far.

I'm behind a company firewall and have properly setup my proxy inside Eclipse and within the IE settings. I can search and download any Eclipse updates without any issues, but can not download the NEON repository.

I can browse to https://tools.hana.ondemand.com/neon/ at least I get a valid page. But obviously the IDE tries to download from this URL https://tools.hana.ondemand.com/neon/content.xml and returns a 404 sometimes the IDE tries to download from https://tools.hana.ondemand.com/neon/content.jar but does not succeed either. When downloading content.jar from within ID 11, I can download a binary content. So does the Eclipse IDE not expect a binary file or does it have the wrong content or version?

Btw. I know the FAQ at https://archive.sap.com/documents/docs/DOC-28325 but the tips do not solve my problem either.

Question: is the NEON repository down right now or delivering the wrong content? Can anybody checks this if one can reach this site?

Did I miss something obvious during my setup?

Thanks,

Michael

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Raghu Govindarajan Dec 07, 2016 at 05:32 PM
0

https://tools.hana.ondemand.com/neon/ works fine for me, actually worked so fast I had to double check that Eclipse was not presenting a cached entry. I just went into Help -> Install new software and added a location using the button on the top right.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Dec 08, 2016 at 12:12 AM
0

Hey mate, i had the same issue. We have a proxy server at my work. What this does is it resigns the certificate causing your issue.

What you have to do is get the resigned certificate and import it into your java certificates. I followed the steps in the below link and was then able to download the tools :) (I cant remember how to get the certificate off the top of my head but you use the url https://tools.hana.ondemand.com/neon/) This makes the cert available to the java program (Eclipse)

http://stackoverflow.com/questions/11617210/how-to-properly-import-a-selfsigned-certificate-into-java-keystore-that-is-avail

Edit: I just recalled how i got the certificate. As our network doesnt allow access to certificates in Internet Options, I used mozilla firefox. Tools -> Options -> Advanced -> Certificates. Find the *.hana.ondemand.com one and export it. Then follow the stack overflow link answers instructions. Make sure you have been to the https://tools.hana.ondemand.com/neon and added the certificate/exception if prompted

Share
10 |10000 characters needed characters left characters exceeded