Skip to Content
avatar image
Former Member

Messages are not reaching to Adapter Engine (JMS receiver)

Hi Friends,

We have one scenario running on Production env.

Scenario is: R3(IDOC) -> XI ->JMS Provider

IDOC to JMS.

Sometime we found messsages are successful in SXMB_MONI, but those messages entries are not found under AE.

Means they are not reaching to JMS.

Communication channel is green, without any error.

This happens sometime only, and no changes have been done to JMS adapter parameters.

What might have happen to these messages, which are successful in MONI but not visible under AE.(Even not in Archived option)?

I searched on SDN, but most of the questions are unanswered.

Please let me know your inputs.

Divyesh Vasani

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Nov 01, 2010 at 02:05 PM

    in message monitoring, via adapter engine you should see the messages

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 01, 2010 at 03:55 PM

    Hi,

    Check in RWB->End to End monitoring or message monitoring to know the over all status of the message...

    if it is in ToBeDelivered or Waiting state then the message has Quality of service EO or EOIO...

    if it is EOIO then unblock the parent message...

    HTH

    Rajesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2010 at 09:04 AM

    Hi,

    Did you have a different retention period for deletion of successful messages in Integration Engine and Adapter Engine?

    Lets say the messages are kept in IE for 7 days but in AE only for 1 day.

    regards,

    francis

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2010 at 10:30 AM

    Hi Divyesh,

    check under message monitoring in RWB

    if u r not finding the message there , those might be archived.

    did u confirm with the destination system .. if they got the messages?

    if at all messages are stuch in AE ... and if u search the correct message u should be able to see the message.

    if the Integration engine unable to put messages in AE , then in some pipeline step in MONI it will show error

    Add comment
    10|10000 characters needed characters exceeded