Skip to Content
author's profile photo Former Member
Former Member

Approval Procedure - Query not working

HI All,

I am trying to add an approval procedure for sales orders with a query attached.

I only want to issue approval if the customer has property 10 ticked within their 'business partner master data' screen

I have created the query below

SELECT 'True'

FROM ORDR T0 JOIN OCRD T1 on T0.[CardCode] = T1.[CardCode]

WHERE T1.[QryGroup10] = 'Y' AND T0.[DocNum] = $[$8.0.0]

But when testing, the doesn't execute as expected, does anyone have any ideas ??

The system is currently at 8.8 PL10

Thanks in advance......

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2010 at 12:47 PM

    Hi Joe........

    try this.....

    SELECT 'True'
    FROM ORDR T0 JOIN OCRD T1 on T0.CardCode = T1.CardCode
    WHERE T1.QryGroup10 = 'Y' AND T0.CardCode = $[ORDR.CardCode.0]

    Hope this will solve your problem......

    Regards,

    Rahul

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.