Skip to Content
author's profile photo Former Member
Former Member

Before and After Image ODS issue

Is there anything must be done manually to the ODS/DSO to set the Before Image, After Image, Reverse Images, Additve, Overwrite, etc.?

It seems there is a big deal about it, but isn't it supposed to be automatic once the mapping of 0RECORDMODE is set.

By mapping 0RECORDMODE, is it correct that the system knows what to do with the Before Image, after Image, Reverse Images, Additve, Overwrite, etc.

Is there any settings on the ODS/DSO that is required to be manually set?

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2010 at 05:13 PM

    Not again if it is what am thinking. Can't get rid of this thing.

    Anyways, there is no such thing as the Key Part when you're referring to an ODS. It was rather confusing. There are Key Fields and Data Fields.

    It doens't seem correct if you add more or less fields to the Key Field section will make the delta work if you're using the standards.

    Maybe not using the standards that you would have to add less or more fields to the key fields.

    Edited by: Yosemite Sam on Oct 29, 2010 7:13 PM

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Yosemite:

      You're right, the correct term is "Key Fields", in the previous post I made a mistake when referring to it as "Key Part", I'm sorry for the confusion.

      Anyway, it is not clear to me if you managed to solve the problem or if you're still struggling with your data loads, if this is the case, Could you please elaborate?

      -Which is the data source you are working with?

      -Did you map the ROCANCEL field both to the 0STORNO and 0RECORDMODE InfoObjects?

      -Are you using Addition or Overwrite on the Update Rules/Transformation Rules to the DSO?

      -Have you applied any relevant SAP Note to fix this issue?

      In case you have not read the blog by Swapna Gollakota, take a look at it, you might find it useful.

      How does a datasource communicates "DELTA" with BW?

      /people/swapna.gollakota/blog/2007/12/27/how-does-a-datasource-communicates-delta-with-bw

      Regards,

      Francisco Milán.

      Edited by: Francisco Milan on Oct 29, 2010 12:31 PM

  • Posted on Oct 29, 2010 at 01:02 AM

    Hi Yosemite:

    Just make sure you have correctly defined the Key Part Fields on your ODS/DSO, if you include either less or more than the necessary InfoObjects then the Deltas will not work as expected.

    Regards,

    Francisco Milán.

    Edited by: Francisco Milan on Oct 29, 2010 12:21 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 29, 2010 at 06:36 AM

    HI ,

    It is correct that system will take care of it when the 0REOCRDNODE is mapped , but still there are scenarios where special care is required , Check the below notes that explains the same

    Note

    399739 - Questions and answers on InfoObject 0RECORDMODE( old one but still should be useful )

    747037 - Update of before images in ODS objects

    690106 - 0PUR_O01/0PUR_O02/0PUR_DS03: records with mode "R"

    Regards,

    Sathya

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.