Skip to Content
author's profile photo Former Member
Former Member

Workset Map iView does not work with custom role

Hi there,

I have a custom role, created with SRM iViews. Within this role there is a workset map iView. I adapted the "Relative Workset Location" (levelsup etc.) to the correct values.

I know that the values are correct because in SAP Light Framework, the workset map works and shows the correct overview. But when I change to the SAP standard framework (not light), then I get the error "Could not find workset location. Check the 'Relative Workset Location' parameter of this iView."

The SAP standard SRM role works with both frameworks.

So:

1) There must be a difference between the SAP standard role and my custom role. What might it be? Any idea?

2) The difference between light framework and standard framework is, that navigation in light framework works with the request parameter "NavigationTarget". So I assume that when the parameter "NavigationTarget" is not set, the start point for the workset iView might not be found within custom role.

Did anyone have the same problem or any ideas?

Thanks a lot in advance for your help.

Best Regards

Joschi

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 31, 2010 at 09:34 AM

    Hi Joschi ,

    Have you tried creating a structure (for your custom role) which is similar to the standard role with either of the framework page . I hope you have tried replicating the same structure/heirarchy with your custom role .

    Also try this once and see if it helps . Under your role place the worksetmap iview and create a folder(at second postion) . Under this folder again place worksetmap iview (first position) and then place the remaining iviews . Put the value levelsup=1 in both the worksetmap iviews .

    Regards

    Mayank

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.