Skip to Content
author's profile photo Former Member
Former Member

Retrans -d return 0012

Hello everybody,

I have oracle connection problem.

when I use the command R3trans -d it returs 0012 code.

The trans.log displays as

4 ETW000 r3trans version 6.14 (release 700 - 05.03.09 - 08:28:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 27.10.2010 - 11:51:24

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: r3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Wed Oct 27 11:51:26 2010 9767 0.009767

4 ETW000 [dev trc ,00000] db_con_init called 22 0.009789

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 38 0.009827

4 ETW000 [dev trc ,00000] Loading DB library 'dboraslib.dll' ... 29 0.009856

4 ETW000 [dev trc ,00000] load shared library (dboraslib.dll), hdl 0 87917 0.097773

4 ETW000 [dev trc ,00000] using "D:\usr\sap\IDS\SYS\exe\uc\NTAMD64\dboraslib.dll" 27 0.097800

4 ETW000 [dev trc ,00000] Library 'dboraslib.dll' loaded 15 0.097815

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library dboraslib.dll 6584 0.104399

4 ETW000 [dev trc ,00000] Version of 'dboraslib.dll' is "700.08", patchlevel (0.201) 52334 0.156733

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library dboraslib.dll 19 0.156752

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library dboraslib.dll 20 0.156772

4 ETW000 [dev trc ,00000] New connection 0 created 6749 0.163521

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 36 0.163557

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 18 0.163575

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse: 13 0.163588

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 27 0.163615

4 ETW000 [dbsloci. ,00000] *** ERROR => Cannot connect: dbs/ora/tnsname in profile missing 1055 0.164670

2EETW169 no connect possible: "DBMS = ORACLE --- ORACLE_SID = 'IDS'"

I have also the parameter in DEFAULT profile dbs/ora/tnsname in profile missing but unable to connect.

Second thing ,when I trying to logon server then give the error message Error in sysntax errot

SAPLSFES.

Please suggest me the how to solve the same.

Thanks

Rajesh

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 27, 2010 at 07:16 AM

    Hi rsatalkar,

    Which user you are running R3Trans? It should be sid<adm> user. Is it correct?

    Plus, add dbs_ora_tnsname=<SID> to your environmet variable on the user.

    Best regards,

    Orkun Gedik

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 27, 2010 at 11:13 AM

    I had restored the backup

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.