Skip to Content
author's profile photo Former Member
Former Member

Database migration to MAXDB for ECC 6.0

Hi Experts,

I have been in process of testing database migration from oracle to MAXDB(SAPDB). I have exported database of size 900GB by using package and table level splitting method in 12 hr.

Now I am importing into MAXDB. But the import is running very slow.

System is configured with 8CPU. Cache size for DB instance is allocated with 10GB. I have running R3load process with parallel 16 CPU processes. Still import is going slowly with more that 32 hrs.

So cloud some on suggest for performance improvement of this import process.

Please let me know for further information.

Regards

Santosh

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Oct 27, 2010 at 05:35 PM

    Hello,

    check this material from SAP:

    System Copy and Migration

    then click on "System copy optimization"

    System Copy and Migration?rid=/library/uuid/8091fedf-5346-2a10-e4a0-a3cafe860199

    This is perfect document on how to speed up the migration.

    I would highligh one fact: If source or target database is MaxDB (your case) - you should be using sorted unload - see Note 954268 - Optimization of export: Unsorted unloading. (Just to eliminate that this is not the problem.)

    In case you are not happy with performace I would suggest to review database configuration (especially parameter CACHE_SIZE and MAXCPU).

    After the migration you can also review the import process using MigTime tool and maybe adjust the table/package splitting or defining package order (but this is usually problem for export).

    If you identify the problem - please come back to share what was the problem and solution.

    Best Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 01, 2010 at 05:59 PM

    > System is configured with 8CPU. Cache size for DB instance is allocated with 10GB. I have running R3load process with parallel 16 CPU processes. Still import is going slowly with more that 32 hrs.

    If you don't use specific options your import will be serialized due to the fact, that R3load triggers a savepoint after each table, even empty ones. Use the very latest R3load and libdbsl on the import system.

    For that system configuration I'd configure the migration monitor as follows:

    -merge_bck -force_repeat -loadprocedure FAST -para_cnt 16

    Also increase the value of the database parameter

    MaxTempFilesPerIndexCreation

    For the time of the import I'd even give the database more memory to keep more data inside, this will increase the time for creating indexes.

    Check what the database is doing by executing

    x_cons <SID> sh ac 1

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

    • > DB cache Size 12G

      > No of parrallel jobs 16

      > MAXCPU 8

      > R3load options -merge_bck -force_repeat -para_cnt 16 -loadprocedure FAST

      > MaxTempFilesPerIndexCreation 4096

      I would set "MaxTempFilesPerIndexCreation" to 131072.

      The question is: what is taking so long? What's your database doing in all the time?

      Did you try to evaluate the times using the time analyzer? (Note 784118 - System Copy Java Tools)

      Markus

  • author's profile photo Former Member
    Former Member
    Posted on Dec 16, 2011 at 04:33 AM

    Answered

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.