Skip to Content
author's profile photo Former Member
Former Member

Conditional Routing using standard context objects failing in PI 7.1Ehp1

Hi All,

I have a [scenario|http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/16541] [original link is broken] [original link is broken] [original link is broken];(please refer link) in which I am setting standard context objects "URLParamOne", "URLParamTwo" in my UDF to determine my interface dynamically at runtime. The scenario was working until our PI 7.1 system was upgraded to PI 7.1Ehp1. Now when I try to test the scenario my message is failing giving error "Unable to find an inbound interface" even though I could see that my UDF is setting the parameters as it is required to do.

What I am guessing is that there is difference in parameters which my UDF is setting and the ones which Interface determination is refering to because the parameters "URLParamOne", "URLParamTwo" are present in both the software components SAP BASIS 7.10 and SAP BASIS 7.11.

Does any body know any setting where we define that parameters refered in interface determination/ receiver determination should refer which software component as with each upgrade the BASIS software component version would change and we need to ensure that configuration objects refer the latest version of BASIS software component version.

Thanks,

Amit

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Oct 13, 2010 at 08:41 PM

    Hi Amit,

    did you try to change the metadata for your communication channel from 7.10 to 7.11?

    Kind regards,

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      After doing some trial and error and the SAP note on HTTP adapter, we were able to fix the issue by changing the name of the parameter in my UDF as UrlParamOne instead of URLParamOne because one SAP note specifies that there is case sensitiveness in parameter and with PI 7.11 documetation of HTTP adapter parameter is not maintained properly.

      Thanks for all help.

      Regards,

      Amit

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.