Skip to Content
author's profile photo Former Member
Former Member

CR XI R2: Appends "1" after table name

I am using Crystal XI R2 product version 11.5.12.1838 and every time I connect to a database and insert a table, a "1" gets a appended to the table name (i.e, PD.PATRON1). Is there a fix or registry setting change for this? My PC is on Windows 7. I am connecting to a UniVerse database with ODBC driver version 4.00.04.7346. It doesn't seem to affect anything reporting wise as I assume Crystal handles it like an alias. It did not do this in previous versions of Crystal, but I was also using Crystal XI R1 on Windows XP and just recently got switched over.

Thanks in advance for your answer!

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Oct 13, 2010 at 01:22 PM

    Hi Marty,

    As noted, CR is Aliasing the table name because something in the name it doesn't like. Possibly the . in the name. I don't recognize the database so not sure it that is part of the table name qualifier or not.

    Most DB's won't allow the basic shifted keyboard character sets to be used, usually they are reserved. CR would then or should write the field name as DB_PATRON.

    Can you rename the table removing the "1"?

    CR XI R2 is past it's end of patch life cycle, no option to get this fixed now. All you can do is use work arounds.

    Thank You

    Don

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.