Skip to Content

Problem in JMS-Adapter with CharacterSet Websphere MQ

Hi,

we have the following scenario:

JMS -> PI -> File

We have a local Websphere MQ Queue Manager and the follwoing configuration in our sender adapter:

Transport-Protocol: WebSphere MQ (non JMS)

Message-Protocol: JMS 1.x

ConnectionFactory: com.ibm.mq.jms.MQQueueConnectionFactory

Java-class Queue: com.ibm.mq.jms.MQQueue

CCSID: 819

Transport: TCP/IP

JMS-conform: WebSphere MQ (non JMS)

In the local queue manager the messages (XML-Messages with header <?xml version="1.0" encoding="ISO-8859-1"?>) have characterSet 819 (ISO-8859-1). That's correct. You can open the files with XMLSpy and it works.

When we receive the messages by our JMS Sender Adapter all the character seems to be in UTF-8 and I don't know why. All the special characters are wrong cause the header of the XML-message shows ISO-8859-1 but all the signs are decoded in UTF-8.

In the other direction (JMS Receiver adapter, File -> PI - JMS) we have the same problem.

We create a ISO-8859-1 message in mapping (and it is really ISO-8859-1) and send it via JMS Receiver Adapter to the local message queue. But there the message arrives in UTF-8 encoding. I don't understand this.

Does anybody know what could be the cause for this?

Does the JMS adapter convert the messages from ISO-8859-1 into UTF-8?

Are there any parameters we have to set?

I hope anybody has an idea what's wrong.

Regards

Thorsten

Edited by: Thorsten Hautz on Oct 12, 2010 5:42 PM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2010 at 06:05 PM

    You can set the character set ID in JMS channel configuration-

    http://help.sap.com/saphelp_nw70/helpdata/EN/c1/739c4186c2a409e10000000a155106/content.htm

    Refer ques-6 in SAP note: 1086303

    Also refer the note- 1346110

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 12, 2010 at 09:51 PM

    > CCSID: 819

    When you assign a CCSID, then the JMS adapter converts to UTF-8.

    When there is no CCSID, then no conversion takes place. (This is similar to file adapter)

    So leave the field empty.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      thanks a lot for your support.

      We could solve the problem now.

      After setting CCSID to 819 and the parameter JMS.TextMessage.charset to ISO-8859-1 (in Sender and in Receiver Adapter) it works fine. I only found a hint to this parameter in note 1346110 and not in the documentation.

      Regards

      Thorsten

  • author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2010 at 04:08 PM

    Hi,

    Please check the your driver settings once in JMS adapter. please refer the below links it may be helpful.

    /people/william.li/blog/2006/11/13/how-to-use-saps-webas-j2ees-jms-queue-in-exchange-infrastructure

    http://help.sap.com/saphelpnw04/helpdata/en/cd/d85a9d6fab7d4dbb7ae421f710626c/content.htm_

    Thanks,

    Amar.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.