Skip to Content
author's profile photo Former Member
Former Member

Strange Problem in Mapping

Hello,

When I execute the mapping manually in the production I get field "Storage location" populated correctly in my Target structure.

But through interface with same payload this field is empty and not getting populated. I cheked in trace that after the mapping is executed the value is blank.

Can you please suggest??

Regards,

Vinit

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    Posted on Oct 13, 2010 at 04:59 PM

    Hi,

    Please follow these steps

    1. in SXMB_Moni -> Copy payload from the step before request message mapping.

    2. Open Message mapping -> test -> Src - and paste the payload here for 1record and and see if it can generate any target field.

    It won't generate any record.

    3. Now close and open Message mapping again -> test and input field and then go to src and copy that xml and make ur source xml exactly like that and try to send msg again.

    Hope this will help you.

    Regards

    Aashish Sinha

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2010 at 02:41 PM

    Hi

    Kindly follow the below steps,

    Edit and activate the mapping again.

    Check and Update the cache notification in IR.

    Regards

    Ramg

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2010 at 02:59 PM

    Hi vinit,

    Check in runtime work bench of component montoring with same payload once, it may populat if there exist any error in your mapping.

    Thanks,

    Amar.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 13, 2010 at 02:58 PM

    Hi Vinit,

    Is there any multi mapping involved in this? If yes, Whats the source of payload? FIle?

    Thanks

    -Kulwant

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 13, 2010 at 04:07 PM

    Using the debug mode, you will see where the problem happen.

    There are some situation that the interface payload format is different from message mapping payload, e.g multi-mapping etc.

    When you pasted payload in interface mapping, make sure format matched what interface mapping requires, so there is no red dot in the source side.

    The other point to make sure your cache is updated by trying to re-activate your interface mapping program.

    Regards

    Liang

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.