Skip to Content
author's profile photo Former Member
Former Member

BEx query - Infoview - obbligation add a mesure

Hi to all,

could you please explain me why if a create a new infoview report with two or more caracteristics I MUST add a mesure in order to have the correct result.

In fact I have selected the following characteristics (dimensions) in my infoview query:

- Customer ID

- ZIp code

And I filter the "Customer ID" field in order to fix only one record(eq Customer ID = 000001)

The result set is the following

cust ID ZIP

-


000001 1

000001 2

000001 3

000001 4

000001 5

000001 6

... ...

It looks like a strange "cartesian product". It seems that the same customer Id is repeted the exact number of the row retriveid by me BEX query.

Could you please explain me this behaviour ?

Thank'you very much!

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2010 at 02:54 PM

    Unfortunately it's by design.

    I'd say that without a measure (the fact table or pseudo fact if you're reporting on an infoobject/DSO) it can't relate two dimensions and so creates a carthesian product.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Ingo Hilgefort

      Hi,

      yes I'm trying to create a report very simple in order to understand an caractheristic of a customer.

      Indeed in my query filter of my infoview I select the interesting customer.

      I attempt only one line as a result.

      but when the query runs I have more than one records...so because there is a cartesian product between my two dimension.

      Do you think that this is a restriction or bug of the query bex / integration of bo with bw ?

      Thank'you in advance.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 13, 2010 at 07:19 AM

    Yep you can do that.

    To access ODS/DSO or Multiprovider or Infoset & Infocube(Navigational attributes) one has to design BEx query on top of it.

    Create BEx query on top of ODS/DSO and check "Allow External Access" Enabled.

    (BW3.x ==>> properties ==>> Extended tab)

    (BI7.0 ==>> Properties ==>> Advanced tab)

    Hope it helps you.

    Thank You!!

    Sent from iPhone

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2010 at 03:09 PM

    Obviously, it's correct only.

    COZ without numerical info none of Report/ Business make sense. As per Characteristics defined in cube, it's relating data and showing data as it has no fact/numeric info.

    Did you check data at BEx by taking same objects?? and how abt data??

    Thank You!!

    Sent from iPhone

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.