Skip to Content
author's profile photo Former Member
Former Member

Virtual InfoProvider Based on 3.x Data Source - Selection Filter Ignored

Hi all,

I have a virtual infoprovider based on 3.X Data source. I built a query on top of this infoprovider with characteristic restriction but it is ignoring the filter and returning all data.

When I tried to go directly to the infoprovider via RSA1 and do a display data with filter selection, it also returns all data.

The data source is supposed to return all data to BW, but I thought we can filter it at BW level.

I tried going to RSRT and changing the properties :

X Query to read data during navigation

H Query to read when you navigate or expand heirarchies

Any help/suggestion appreciated.

Thanks.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 13, 2010 at 08:38 PM

    Just a sugguestion.

    If the DataSource is based on a function module, the function module may not be able to process the characteristic value selection. Consider changing the funtion module.

    John Hawk

    Edited by: John Hawk on Oct 13, 2010 1:38 PM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.