Skip to Content
avatar image
Former Member

How to configure SAP Portal 7.01 to use LDAP with SSL?

I need to configure my 7.01 SAP Portal to access an AD server and use LDAP over SSL.

It is currently configured to access the AD without the use of SSL.

I have imported the SSL certificate from the AD server (as per http://help.sap.com/saphelp_nw70ehp1/helpdata/en/fa/dc74a374ec4b91a9e8eb84966d3329/frameset.htm).

Also, I have changed the LDAP configuration (as per http://help.sap.com/saphelp_nw70ehp1/helpdata/en/2c/8f0faf4cc446b8a125ff682a95c1ae/frameset.htm) by changing:

Server Port = 3269 (I have also tried 636)

Use SSL for LDAP Access = ticked

When I test the connection, I get the error: 'Connection test with user path failed'

Then if I click on 'User Path | Browse' and then click on 'mydomainname:3269', I get the error 'Connection to LDAP server failed; check credentials'.

I cannot see any entries in the Security.0.log file.

Please can you tell me what the issue might be?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 11, 2010 at 03:34 PM

    may be not related but can you please make sure that the port 3269 is opened from your portal and LDAP servers?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      The port is open and there are no firewalls.

      I have just found the answer - I had entered the hostname, not the FQDNS! It is now working.

      Thanks.

  • avatar image
    Former Member
    Oct 11, 2010 at 03:39 PM

    Had to use the FQDNS.

    Add comment
    10|10000 characters needed characters exceeded