Skip to Content

MII 12.1 and JDK

We finally got a development box going for MII 12.1, and I was told that they installed SAP JDK 1.5 on this server. I asked our Netweaver Basis person who set this up if he meant SUN JDK, and he said no, they don't use SUN JDK. I didn't know that SAP made their own JDK version.

My question is: I assume this version will work fine for MII 12.1, and if so, what is the minimum release level?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 07, 2010 at 08:55 PM

    Hi Todd,

    talking of the server, SAP MII 12.1 runs on NetWeaver CE 7.1 EHP1 SP03 with the [SAP JVM 5.1|https://cw.sdn.sap.com/cw/docs/DOC-112498]. You find more info in the [Product Availability Matrix (PAM)|http://service.sap.com/pam]. Search for MII.

    On the clients that use the MII 12.1 portal, at least Java Runtime Environment (JRE) 1.5 or higher must be installed (but not 1.5.0.07, 1.5.0.08 and 1.5.0.09). You can find more info in the instguide for MII 12.1 (service.sap.com/instguides > SAP Business Suite Applications > Manufacturing > SAP Manufacturing Integration and Intelligence).

    Michael

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 07, 2010 at 08:11 PM

    Hi,

    for SAP MII 12.1

    MII will be deployed on NetWeaver CE, JDK 1.5 based

    JDK will provide you run time environment and lot off features

    didn't know that SAP made their own JDK version.

    As per my knowledge SAP heaven't made JDK and all.

    But I am using Java version 6 update above 13 for SAP MII 12.1 and it is working fine.

    and latest is version 6 update above 21 as per my knowledge.

    that you can download from following link.

    [http://www.java.com/en/download/chrome.jsp?locale=en&host=www.java.com]

    I can suggest you go through following thread to understand JDK

    [http://en.wikipedia.org/wiki/JDK]

    hope this helps!!

    Regards,

    Manoj Bilthare

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 08, 2010 at 05:25 PM

    OK, so it's the JVM. Thanks for the information.

    Add comment
    10|10000 characters needed characters exceeded