Skip to Content
author's profile photo
Former Member

How to convert MDT scenario RPT0 to launchpad

Hello,

I'm trying to turn on the reporting launchpad in MSS. I am trying to use the delivered scenario of RPT0 and I've added a new tcode function to it. When I run the IMG step "Convert MDT Data to MSS Reporting Launch Pad" I get the message that no MDT entries are found.

Why is it not finding the RPT0 entries? Is there an additional config step I'm missing? Also, I'm not sure if this relates to this issue, but the IMG step under MSS for setting up the launchpad does not exist in our system. I can't seem to find what activates it but I'd appreciate input on this if you've seen it before. I can get to tcode FPB_LP_MSS_REP_CUST if I enter it manually.

Thanks,

Eric

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Best Answer
    Posted on Oct 06, 2010 at 05:34 PM

    what is the scenario of your reports?

    Please check the steps in

    http://wiki.sdn.sap.com/wiki/pages/viewpage.action?pageId=199820849

    and also run test report in backend and see what error you get?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I am initially trying to get scenario RPT0 up for testing before creating a custom scenario. I show RPT0 is defined in the IMG steps under "Define Scenario-Specific Settings". I created 2 custom function codes (a NODE and a REPO) under "Define Function Codes" and have added them under Scenario RPT0, higher level function code MSS_HOME in step "Define Structure of Function Codes".

      When I run the convert program it doesn't find anything. I also just tried testing the report with PWPC_RPT_START_REPORT_TEST from the link provide. Scenario RPT0, and my custom REPO function code for tcode CAT3 and get the error "Error in MSS, When calling the report, the following error occured: System = SBX, Error when executing function". I also get the same error when trying to test the delivered MSS_NODE_RW function code.

  • Posted on Dec 09, 2010 at 02:04 AM

    did you check this link

    http://wiki.sdn.sap.com/wiki/pages/viewpage.action?pageId=199820849

    it has all the steps!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Siddharth,

      I have checked that site and am still having issues.

      All of the services and resources are/were setup the way you have described, and we are using RPT0 from what I can tell. I have not built a custom object. I have not done any work to the MDT in backend, but when I go to tcode PPMDT I can successfully run the standard reports in backend (like birthdays). If I run report PWPC_CONV_MDT_TO_LPA is it supposed to pull those backend MDT reports into the portal launchpad? When I'm running it for scenario RPT0 it doesn't find any applications. Testing in PWPC_RPT_START_REPORT_TEST also does not create any results when using scenario RPT0 and FC "MSS_HOME". The screen just sits there.

      I am however able to use FPB_LAUNCHPAD_CUST for Role MSS and Instance REP to add tcodes. Now those tcodes do appear in the portal iview, but they do not function when I try to test them. I've added two tcode applications for transaction I know I have access to and also added a URL application. They all return an error. My iview application parameters are "role=MSS&instance=REP&display_external=X&INITIATOR_ROLE=HRASRB".

      Can you tell what I'm missing or may be doing wrong?

      Thanks,

      Eric

  • author's profile photo
    Former Member
    Posted on Oct 06, 2010 at 03:47 PM

    Hi check the documentation :

    HR250-SAPEmployeeSelf-Service

    HR260 Manager Self Services in HCM

    HR290 System Configuration for ESS-MSS

    Regards

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 06, 2010 at 06:31 PM

    report category should be rpt0, ensure steps are followed in above wiki

    you need to adjust iview properties if you use another report category

    Therefore the best option would be to change the report category to

    "RPT0" in the backend system for all your reports.

    ie

    2)Their is an Iview property called "Scenario" in the reporting iview.

    By default this property is set as "RPT0" . When the reports are

    accessed by the user the scenario type is forward to the backend along

    with other selection parameters. The backend function modules use this

    information to identify the report. There are times when customers

    configure the report category type differently (Z***) for their function

    codes in the table: T77MWBFCH "Table for function code hierarchies for

    manager desktop". However with ERP2005 only scenario type: RPT0 is

    delivered by default. If you observe this issue in your system than you

    have two choices to get around this problem.

    1)Change the Iview property "Scenario" of the Reporting iview from

    "RPT0" to your own type"Z***", than this set of reports will work.

    however, the standard reports will not work.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Siddharth,

      Does the resulting iview properties effect testing it in the backend from the program you provided on that wiki? I ask because I'm getting the errors I mentioned, which seem to me like I'm still a step short of even having anything to display in the iview? If the backend test fails I wouldn't think the iview is the issue at this point?

  • Posted on Oct 06, 2010 at 07:08 PM

    yes you are right. it shouldnt effect but i think i checks the resource on how it is maintained, You can debug and find out

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Barin,

      Thanks for the reply and sorry for my delay. I've never configured the reporting launchpadd for MSS so maybe that is my confusion. I was under the impression that for it to work in MSS, I needed to configure the MDT and then convert it. Since your post we've applied some changes to portal to bring it up to date and get rid of some mis-match issues. With those changes I'm still having the MDT error, but found that I can now add tcodes through transaction FPB_LP_MSS_REP_CUST. Those transactions now appear (though still don't work) on the reporting page in MSS. Any direction you can provide would be appreciated.

      Thanks,

      Eric

  • Posted on Dec 09, 2010 at 11:28 PM

    can you check your customisation from the backend

    check URL OF PCD PATH in table V_T7XSSSERRES, Please

    check this resource

    can you paste your configuratoin of the resource and test with the above FM in the backend what error you get?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Siddharth,

      I have modified the URL of PCD page, so my record is in V_T7XSSSERRESC. Entries are below:

      Directory path = sap.com/mss~rpt

      Object name = LPAReporting

      URL param = sap.xss.rpt.scenario=RPT0&sap.xss.rpt.viewgroup=REPORTING&sap.xss.rpt.visiblerowcount=0

      Window name = _blank

      URL of PCD = ROLES://portal_content/com.SFHS.SFHS_Folder/Eric_MSS_Test/com.sap.pct.erp.mss.manager_self

      service/com.sap.pct.erp.mss.manager/com.sap.pct.erp.mss.reports/com.sap.pct.erp.mss.reportsp

      age/com.sap.pct.erp.common.reportlaunchpadpcd_page

      The URL of PCD matches the object ID of the iview details.

      If I run PWPC_RPT_START_REPORT_TEST for Scenario RPT0 and Function Code MSS_HOME, it runs for a second, but then nothing happens and the screen does not change. If I only enter a scenario, RPT0, and run it I get "error when executing function".

      I have used FPB_LAUNCHPAD_CUST to update MSS / REP and add tcodes SU01, CAT3, and S_PH9_46000221 as well as a URL for google.com for testing. The URL link gives a page cannot be displayed message and the tcodes give me a portal runtime error /exception message. Here is part of the message:

      Exception ID:10:29_10/12/10_0011_3277051

      [EXCEPTION]

      com.sapportals.portal.prt.component.PortalComponentException: Error in service call of Portal Component

      Component : pcd:portal_content/com.sap.pct/every_user/com.sap.pct.erp.common.bp_folder/com.sap.pct.erp.common.iviews/com.sap.pct.erp.common.transaction_dummy

      Component class : com.sapportals.portal.sapapplication.SAPApplicationIntegratorComponent

      Thanks for the help in determining the issue.

  • Posted on Dec 10, 2010 at 08:11 PM

    can you please check directly in portal

    ie in Please test the following go to portal >> content administration >>

    its an issue with roles

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I get the same results navigating through the PCD and previewing the ivew. I had SAP_ALL added in the backend and my portal roles are listed below. Most of my MSS testing has been through the Eric Test role, but I also made the changes and tried it under the standard MSS role with the same results.

      pcd:portal_content/administrator/super_admin/super_admin_role -Super Administration Portal Role

      pcd:portal_content/com.sap.pct/line_manager/com.sap.pct.erp.mss.bp_folder/com.sap.pct.erp.mss.roles/com.sap.pct.erp.mss.manager_self_service -Manager Self-Service Portal Role

      pcd:portal_content/com.saintfrancis.SFHS_export/com.sap.pct.erp.ess.SFHS_employee_self_service_0 -SFHS Employee Self-Service Portal Role

      pcd:portal_content/com.sap.pct/every_user/com.sap.pct.erp.common.bp_folder/com.sap.pct.erp.common.roles/com.sap.pct.erp.common.erp_common -ERP Common Portal Role

      pcd:portal_content/com.SFHS.SFHS_Folder/Eric_MSS_Test/com.sap.pct.erp.mss.manager_self_service -Eric Test - Manager Self-Service - Delta link Portal Role

  • author's profile photo
    Former Member
    Posted on Dec 22, 2010 at 03:28 PM

    Resolved. It was a Web AS issue.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Graham,

      I am also facing the same issue. I am getting the same error message that the scenario does not exist. Could you please share the information if you were able to resolve this issue?

      Hello Eric,

      Could you also please share your thoughts on what you changed with the Web AS path to fix the issue?

      Thanks much for your inputs!

      ~~Maria Kutty