Skip to Content
-1

Develop Java 8 Apps in NWDS 7.3 for the NetWeaver Portal 7.3 or 7.4

Dec 06, 2016 at 11:03 AM

403

avatar image
Former Member

Hi Folks,

Have somebody an idea or a HowTo, how to

develop Java 8 Apps in NWDS 7.3 for the NetWeaver Portal 7.3 or 7.4

Can somebody pls help me?
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Peter Tari
Dec 10, 2016 at 04:30 PM
4

Hello Arthur,

If you have NWDS 7.3x it means you have a Portal (or other AS Java) 7.3 or 7.4, exactly as you wrote. But with these releases you have to stick with lower JDK, that is 1.6. Only NetWeaver AS Java 7.5 support Java 8.

Best Regards,

Peter

Share
10 |10000 characters needed characters left characters exceeded
Szabolcs Renyo
Jan 06, 2017 at 10:13 AM
2

Hello Arthur,

Here you can find more information about the Compatibility between the SAP JVM (JDK) and the NetWeaver release:
https://wiki.scn.sap.com/wiki/display/ASJAVA/SAP+JVM+Netweaver+compatibility+and+Installation

As Peter mentioned NetWeaver 7.5 supports Java 8.

Best Regards,
Szabolcs

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you for this information!

But which J2EE Version does NetWeaver 7.5 supports?

We would like to develope in J2EE 7. ;-)

Best Regards

Arthur

0

Hello Arthur,

As you can see in the link we don't support that develop to NetWeaver with JVM 7.

If you would like to develop to NetWeaver 7.5 you have to use JVM 8.

If your runtime system has 7.30/7.31/7.40 realase you have to use JVM 6.

Best regards,

Szabolcs

3
Former Member
Szabolcs Renyo

Hello Szabolcs,

Yes, I know. You talk about the JVM 8 Version! I understand.

But I talk about the J2EE Version.

https://en.wikipedia.org/wiki/Java_EE_version_history

Best regards,

Arthur

0

Arthur, your question has been answered. The JVM version is the J2EE version for all intents and purposes. If you are using NetWeaver 7.5, then it is running on SAPJVM 8 (or 8.1), and that is what you must develop with. That is the equivalent of JDK 1.8 (or J2EE 8) outside of SAP.

Cheers,
Matt

2
Ervin Szolke
Jan 24, 2017 at 01:03 AM
1

Hello Arthur,

Please refer to Peter's answer (and review the other answers and comments as well)

The 7.50 release of AS JAVA (a.k.a J2EE Engine) runs with SAPVM 8 (this acts like a JRE) on server side, and expects NWDS 7.5 on client side that uses a 1.8 JDK (usually again SAPVM8 recommended that includes the SDK part).

In this context 1.7 cannot be used.

730/740 J2EE Engine runs with SAPVM6 and expects NWDS 730/731 that expects JDK1.6.

I am not sure there is a J2EE Engine of any Netweaver AS JAVA releases that would use a JVM7.

There is no version of NWDS you could run with a JDK1.7.

I am not sure either tricking with with 1.7 compile mode would be a way out here.

Best Regards

Ervin

Share
10 |10000 characters needed characters left characters exceeded
Jun Wu Jan 24, 2017 at 02:45 AM
1

they only support JEE5 for nw java platform,

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 06, 2017 at 08:46 AM
0

Okay, I have now installed a Portal 7.5 AS Java.

Where can I find the Information which J2EE Version I can Use?

I would like to use J2EE 7.

Is it possible?

How?

Best Regards,

Arthur

Share
10 |10000 characters needed characters left characters exceeded