Skip to Content
avatar image
Former Member

FCC suggestion

HI

I am using FCC for the receiver file adapter_csv file(target side) . I am having four fields MANDT ,LANGU, PROFN, AKTPS

for the last fields AKTPS the data contains comma(,) Example:Bangalore,India.

so that Bangalore is writing in one record and India is writing in another record on the excel file.

but, I want to write Bangalore,India in one record on the excel only. How can i solve this???

my File content conversion parameters are :

record structure:row

row.addHeaderLine : 1

row.headerLine :MANDT,LANGU,PROFN,AKTPS

row.fieldSeparator : ,

row.endSeparator :'nl'

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Oct 06, 2010 at 10:29 AM

    HI,

    I am Not Sure , But what U can Do is In Message Mapping You Can replace comma in Banglore, India with some other symbol

    By Using Graphical Function Or UDF.

    By This way , During FCC on receiver Side , System Will not find any Comma during Conversion Time.

    This Might Solve the Problem ...

    Regards

    Prabhat Sharma.

    Add comment
    10|10000 characters needed characters exceeded

    • >

      > HI,

      >

      > I am Not Sure , But what U can Do is In Message Mapping You Can replace comma in Banglore, India with some other symbol

      >

      > By Using Graphical Function Or UDF.

      >

      > By This way , During FCC on receiver Side , System Will not find any Comma during Conversion Time.

      >

      >

      > This Might Solve the Problem ...

      >

      >

      >

      >

      > Regards

      > Prabhat Sharma.

      No need for any mapping logic to be changes.

      Use the enclosuresign parameter in the FCC as mentioned by supriya.

      ref: http://wiki.sdn.sap.com/wiki/display/XI/FileContentConversion

  • avatar image
    Former Member
    Oct 06, 2010 at 11:27 AM

    Hi,

    I am not sure whether this solution will work or not, but you can give it a try:

    Use row.enclosureSign : "

    In mapping put the double quotation(") for the field AKTPS.

    Eg: "Bangalore,India"

    In the FCC put the above parameter, row.enclosureSign: "

    This parameter works for Sender FCC, I am not sure about the receiver FCC, but you can give it a try and post your observation over here.

    -Supriya.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Supriya Thanks a lot.

      As you suggested i just concated with " both the sides ( "AKTPS") in the mapping.

      now its working fine.

      i didnt done any changes in the FCC parameters in CC Channel. do I need to change the parameters???

      Thanks!

      Vankadoath

  • avatar image
    Former Member
    Oct 06, 2010 at 11:40 AM

    Please refer this thread:

    how-to-handle-a-comma-in-a-field-in-csv-file-durin

    ---Divyesh Vasani

    Add comment
    10|10000 characters needed characters exceeded