Skip to Content
avatar image
Former Member

Invalid transport binding settings HTTP Client, does not have endpoint url

Hi All,

We are working in SAP CE 7.1.

We have created an enterprise service in Enterprise Service Builder and published it in Services Registry.

The implementation is done using EJB and it is built and deployed on the server.

When I test the service in WSNavigator, I get the error..Invalid transport binding settings HTTP Client, does not have endpoint url specified

I tried to search on SCN.

Most of the solutions given are: doing some service endpoint settings in SOAMANAGER AND WSADMIN. But in our case we are by no ways connected to R/3 system.

Observations:

1) When I publish the service from ES builder, after publish I see a popup which says the Release State of the service as 'Not Released' even if I have set it to 'Released'.

2) In Services Registry when I search for my enterprsise service, I can see see the state as 'Modeled' and other services as 'confiured'

3) When I access nwa->SOA Management->Application and Communication Scenario->Single Service Administration and serach for my service, it is not found.

These observations might be useful in finding some solution.

So, my question is:

How to create service endpoints for the enterprise service? (so that the service state becomes 'Configured' from 'Modeled')

Regards,

Radhika

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 06, 2010 at 08:34 AM

    Hi Radhika,

    Have you seen this blog posting:

    [http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/8736] [original link is broken] [original link is broken] [original link is broken];

    You seem to be on the right track and that's where you would create your endpoint but there may be something that you've missed (maybe on the deploy step) that could be why you can't see your service in NWA. The other issue could also be how you're doing your search for the service.

    Regards, Trevor

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Radhika,

      One probably reason is that the service was defined as asynchronous & not synchronous in the ES Builder.

      Regards, Trevor

  • avatar image
    Former Member
    Oct 11, 2010 at 05:26 AM

    Hi,

    Problem Solved.

    1)Right Click EJB Session Bean->Create web service->Develop Service->Select Existing Endpoin->*<serviceinterfacename>* (in my case esr)->Select the service which comes by default.

    2)Go to EJB Session bean. Add 'implements' clause to the class for implementing the service endpoint interface which you selected in the above step.

    3)Build, Deploy EAR

    4)Now, go to /nwa->Application and scenario Communication->Single Service administration->Click on Service Registry radiobutton->Search by name in service registry->esr

    This will show you the service interface which is published in service registry.

    Now, it will show the status as 'Activated/Deployed'.

    5)Select the service interface and click on Configuration tab->Create Endpoint->Follow the steps according to given roadmap.

    6)Now the status of service will change from 'Activated/Deployed' to 'Configured'.

    7)Test the service in wsnavigator.

    Thanks,

    Radhika

    Edited by: Radhika Parag Rajopadhye on Oct 11, 2010 7:39 AM

    Add comment
    10|10000 characters needed characters exceeded