Skip to Content

ASC880_006020: Unable to get property: ControlKey from CPA cacheControlKey

Hi All,

The scenario I am trying to build is Invoice 880 Version 6020 from SOAP to EDI Separator and then from EDI Separator to File.

I have loaded B2B Content SP04 PAT03 (latest at the time of posting this question) into EDI Content Manager.

When I run the scenario without ticking 'Read from Dynamic Headers', the scenario works fine. However, when the option is ticked then the error occurs. Control Key Scenario Association is also filled with the default value of Control Key name SAP and .* as every other value.

Please let me know your thoughts. Thank you.

Kind regards,

Bala

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Dec 06, 2016 at 03:58 PM

    Hi Bala,

    ticking the checkbox "Read from Dynamic Headers" means that you must maintain the Trading Partner Management functionality. A short blog you fill find here: TPM Blog Part 1.

    However you do not need to maintain TPM for working scenarios. Most of my scenarios are running fine without TPM. TPM is only maintained if it is part of a global integration concept.

    Kind regards

    Konrad

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 06, 2016 at 07:01 PM

    Hi Bala,

    Along with what Konrad has shared I would also add that you want to pay attention to your acknowledgement settings. We recently updated our patch level on B2B and noticed these errors when the system tried to generate a 997 acknowledgement even for an incoming 997. If we did not have an appropriate EDI separator sender channel then the system would complain because it could not find a proper sender for the acknowledgement it was trying to send. Be sure that you have all necessary EDI separator sender channels created and active in your integration directory.

    Regards,

    Ryan Crosby

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Ryan.

      I tried adding an Acknowledgement (997) integration flow to the server. However, it did not help.

      The acknowledgement settings were always set to not required.

      Kind regards,

      Bala