Skip to Content
avatar image
Former Member

Delta tokens and JSON in SAP Gateway

Hi Guys

We are currently building a UI5 solution that will be used both online (deployed on gateway or HCP as HTML5 app) and offline (in Kapsel). The goal is to use the same OData service for both scenarios. That has been working fine so far.

We are now stating to optimize performance and have enabled delta tokens in the gateway. Unfortunately this puts the requirement on the service that it must use XML.

The OData offline store has no problem speaking JSON to the model while sending backend requests as XML. So the offline scenario works fine.

But when we run in online mode with OData data model set to JSON we get the error that JSON is not supported for delta tokens. Since we are running online as a web app there is not really a need for delta tokens so what i am wondering is:

Is there a way to make a delta enabled service respond to JSON request when no delta token is passed in?

Br Olav

Add comment
10|10000 characters needed characters exceeded

  • Former Member

    Hi

    Sorry, can I ask you how you enabled the delta tokens in the gateway? We have a really similar scenario and would also like to improve performance.

    Thanks

    Marco

  • Get RSS Feed

2 Answers

  • Jul 10, 2017 at 10:58 AM

    Hello Olav,

    I am not a SAP Gateway expert, as you probably know that if OData producer is SAP (Netweaver) Gateway then you will get DELTAs through XML only (however SAP Mobile Platform 3.0 supports both XML & JSON)

    I would suggest you to reach out to SAP support team by raising an OSS ticket.

    Regards,

    JK (Moderator)

    PS: If your issue has already been addressed, please close this query by providing solutions, it will help others.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 27, 2017 at 12:53 PM

    Hello Olav,

    Did you get any response for the above issue, we also facing the similar kind of issue. Please let us know your feedback.

    Thanks,

    vignesh

    Add comment
    10|10000 characters needed characters exceeded