Skip to Content
avatar image
Former Member

SQL Server error

Hi All,

Whenever trying to connect to the database engine in SQL server management studio, A connection was successfully established with the server, but then an error occurred during the login process. (Provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233). Please Help.

Regards,

Rupa

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 28, 2010 at 12:49 PM

    SQL Server enterprise manager ?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Rupa,

      yes, which Version of SQL server du you have?

      If you use 2005 or 2008 do the following.

      Press Start Button -> All Programmes- > Microsoft SQL Server 2005 or 2008-> SQL Server Management Studio.

      I think you could your Windows loggin to get to the sa User if it is locked.

      best regards,

      Indira

      Edited by: Indira Siebmanns on Sep 28, 2010 3:22 PM

  • avatar image
    Former Member
    Sep 28, 2010 at 11:43 AM

    Hi Rupa,

    Do you have Shared Memory connections enabled? Run the SQL Server Configuration Manager and look at the protocols and shared Memory to see if it is enabled or not.

    If you are getting this erro while connecting to sql express server then you need to make changes mentioned below.

    1. Click on Start menu > Programs > Microsoft Sql Server > Configuration Tools

    2. Select Sql Server Surface Area Configuration.

    3. Now click on Surface Area configuration for services and connections

    4. On the left pane of pop up window click on Remote Connections and Select Local and Remote connections radio button.

    5. Select Using both TCP/IP and named pipes radio button.

    6. click on apply and ok.

    Now when try to connect to sql server using sql username and password u'll get the error mentioned below

    Cannot connect to SQLEXPRESS.

    ADDITIONAL INFORMATION:

    Login failed for user 'username'. The user is not associated with a trusted SQL Server connection. (Microsoft SQL Server, Error: 18452)

    ation

    To fix this error follow steps mentioned below

    1. connect to sql server using window authentication.

    2. Now right click on your server name at the top in left pane and select properties.

    3. Click on security and select sql server and windows authentication mode radio button.

    3. Click on OK.

    4. restart sql server servive by right clicking on server name and select restart.

    Now your problem should be fixed and u'll be able to connect using sql server username and password.

    Thanks

    Sachin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 28, 2010 at 12:25 PM

    Hi Sachin,

    Thanks a lot for relying. Though I did all beforehand what you told, did again now. Still this message comes

    "Login failed for user 'sa'. (Microsoft SQL Server, Error: 18456"

    Regards,

    Rupa

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rupa,

      To resolve this issue, you must add an account to the Database Creators role and to the Security Administrators role

      in SQL Server. You add the account that the application pool is running as. To do this:

      Add the account that the application pool is running as to the Security Administrators role and to the Database Creators role

      in SQL Server. To do this:

      Start SQL Server Enterprise Manager.

      Expand Microsoft SQL Servers, expand the server group, expand the appropriate server, and then expand Security.

      Right-click Logins, and then click New Login.

      Type the account name in the Name box. Use the following format for the account name:

      DomainName\AccountName

      Note If SQL Server is installed on a separate computer and you want to run the application pool as the Network Service account, the computer that is running Windows SharePoint Services must have permissions to access the remote computer that is running SQL Server. On the remote computer that is running SQL Server, add the DomainName\ServerName$ account to the Database Creators role and to the Security Administrators role.

      Click the Server Roles tab.

      In the Server Role list, click to select the Security Administrators check box, and then click to select the Database Creators check box. Click OK.

      Quit SQL Server Enterprise Manager.

      On the Configure Administrative Virtual Server page of SharePoint Central Administration, create a new application pool, specify the account as the application pool account, and then click OK. The Application Pool Changed page is displayed.

      Restart Microsoft Internet Information Services (IIS). To do this, click Start, click Run, type iisreset in the Open box, and then click OK.

      On the Application Pool Changed page, click OK. On the Set Configuration Database Server page of SharePoint Central Administration, specify the configuration database settings.

      Thanks

      Sachin