Skip to Content
avatar image
Former Member

SAP XI-MDM umlaut problem

Hi all,

I have a problem in our PRD environment. Everytime XI passes / transfers a message that contains umlaut characters to MDM, the MDM system blocks the incoming message. Before, in both DEV and QAS, it was working fine. Even though there were umlaut characters, MDM still processed the messages. I tried implementing note 800354 but it did not work. I think that's applicable in MDM 3 only. Our MDM now is 7.1. Any suggestions on how to configure MDM 7.1 in such a way that it will disregard umlaut characters and still process the messages that contain those characters?

Thanks! Any reply would be greatly appreciated..

Regards,

IX

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Sep 28, 2010 at 11:14 AM

    Hi IX,

    With MDM 7.1 Umlaut characters like (Ä, Ö, Ü etc), I am able to load file using MDM Import Manager and can map Source Umlaut Characters field easily with MDM field of Type Text. I am using MDM 7.1 SP04 and l am able to process the messages that contain these characters. Make sure that file saved with Encoding= UTF-8.

    Regards,

    Mandeep Saini

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 28, 2010 at 12:48 PM

    Hi,

    I bet this is an encoding issue. Default encodings aren't always easy to find, it's possible the default encoding used in your production PI is different than the one in your other landscapes.

    The safest way to make sure MDM recognizes unicode files is to add a BOM -- Byte Order Mark -- look for that flag in the system that generates the files for MDM.

    Alon

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 29, 2010 at 03:45 AM

    the error was on my side (XI). the transfer mode of the inbound comm channels should have been Binary instead of Text. Thanks for your replies!

    Add comment
    10|10000 characters needed characters exceeded