Skip to Content
0
Former Member
Sep 21, 2010 at 01:32 PM

Can´t get Workflow Attribute in UWL Display

64 Views

Dear all,

I have to integrate an attribute from standard workflow TS00275253 in UWL.

The field in the workflow container is defined in "_WI_Object_ID" and has the name "VendorName".

Can please anybody explain to me how to integrate this. I did this for attributes definied in the containers root without problems.

These are the configurations I tried yet without any success.

<ItemType name="uwl.task.webflow.TS00275253.SAP_FI" connector="WebFlowConnector" defaultView="Rechnungen_gen" defaultAction="launchMiniApp" executionMode="default">
      <ItemTypeCriteria systemId="SAP_FI" externalType="TS00275253" connector="WebFlowConnector"></ItemTypeCriteria>
      <CustomAttributes>
        <!-- <CustomAttributeSource id="WEBFLOW_CONTAINER" objectIdHolder="externalId" objectType="WebflowContainer" cacheValidity="final">
          <Attribute name="_WI_Object_ID.VendorName" type="string" displayName="Kreditor"></Attribute>
          <Attribute name="InvoiceDate" type="date" displayName="Rechnungsdatum"></Attribute>
        </CustomAttributeSource> -->
        <CustomAttributeSource id="ABAP_BOR" objectIdHolder="externalId" objectType="/ORS/INVAP" cacheValidity="final">
          <Attribute name="_WI_Object_ID.VendorName" type="string" displayName="Kreditor"></Attribute>
          <Attribute name="InvoiceDate" type="date" displayName="Rechnungsdatum"></Attribute>
        </CustomAttributeSource>
      </CustomAttributes>
      <Actions>
        <Action name="launchMiniApp" groupAction="yes" handler="SAPIACLauncher" returnToDetailViewAllowed="yes" launchInNewWindow="yes" launchNewWindowName="WorkItem" launchNewWindowFeatures="resizable=yes,scrollbars=yes,status=yes,toolbar=no,menubar=no,location=no,directories=no">
          <Properties>
            <Property name="ApplicationParameter" value="~Okcode=ONLI&amp;p_action=EXECUTE&amp;p_wi_id=${item.externalId}"></Property>
            <Property name="IAC" value="ZSWNWIEX"></Property>
          </Properties>
          <Descriptions default="Ausführen"></Descriptions>
        </Action>
      </Actions>
    </ItemType>

I tried "WebflowContainer" and "ABAP_BOR" without success.

The field is shown in the UWL header but no values are transfered to the positions.

Thanks for any help.

Best regards

Roman Becker